Skip to content

Commit

Permalink
net-misc/youtube-dl: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Jeroen Roovers committed Apr 26, 2017
1 parent 2536b92 commit 1ccc01d
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/youtube-dl/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.04.11.tar.gz 2671689 SHA256 4df5af6b3199a93a7e4dc58de0c6da6759b065ceeeaac9470865a5cefdfdc149 SHA512 d831505902f4857a1701cc71286b3ad62e60eeafec3cec3ddde2fe74ff24a826b800146986d47c69bc74b1ef4bb15ae39174e1da34d04b19c859ce4c0f140c5b WHIRLPOOL 91a98c60ac9cb45dbfc3870e81d5d538047763136ba6f99ec21df74b6409f78062546e016cc7c4c5e89cdbcca61788382b783c22f2901dfec228e1edf4892c4b
DIST youtube-dl-2017.04.17.tar.gz 2684486 SHA256 326f7ec2e0abe0aada4675987e967120a52ce2599c9b20e0d448de0c9f64302e SHA512 dfe8d762f0fb70dee87cd7156011582ef3cba33ce359a227c8e7e39e76fe51690452b2820e8cd41bf109e19f5e4976c9a2e50cb18533c4161720df0fa858d761 WHIRLPOOL c12269136093ddb2b7e2b9d59bfca2c87f921943b8977c9318400301742208e929f71f3e5bdbb3db9ae08cd7e71ac4dab5f28d2f78e3a855620f0ad06bb8c1b9
DIST youtube-dl-2017.04.26.tar.gz 2691549 SHA256 c320c8301a63ad97c099359c8b205d14c130b4f816dd92f0f5e68481628cfc47 SHA512 45b6e48828da72d4d014ba1605c94efbf7d082ad8527f49ec1333c4d7c210bcb64e68cbd140f505f318890693ed0b45c351d29344eb2162d00613674e60fbdb3 WHIRLPOOL a27b6944d033c9362c4891cc4d1ee8482383675378463f8a706cb9ba61d6245a4147ca7a4124d784aaebc585b052853bba645dec0e1b02446ebfc18af9c9fc97
98 changes: 98 additions & 0 deletions net-misc/youtube-dl/youtube-dl-2017.04.26.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
inherit bash-completion-r1 distutils-r1 eutils

DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://rg3.github.com/youtube-dl/"
SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="+offensive test"

RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
test? ( dev-python/nose[coverage(+)] )
"

S="${WORKDIR}/${PN}"

python_prepare_all() {
if ! use offensive; then
sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
youtube_dl/version.py || die
# these have single line import statements
local xxx=(
alphaporno anysex behindkink camwithher chaturbate eporner
eroprofile extremetube fourtube foxgay goshgay hellporno
hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
myvidster porn91 porncom pornflip pornhd pornotube pornovoisines
pornoxo ruleporn sexu slutload spankbang spankwire sunporno thisav
tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
youjizz youporn
)
# these have multi-line import statements
local mxxx=(
drtuber pornhub redtube tnaflix xhamster
)
# do single line imports
sed -i \
-e $( printf '/%s/d;' ${xxx[@]} ) \
youtube_dl/extractor/extractors.py \
|| die

# do multiple line imports
sed -i \
-e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
youtube_dl/extractor/extractors.py \
|| die

sed -i \
-e $( printf '/%s/d;' ${mxxx[@]} ) \
youtube_dl/extractor/generic.py \
|| die

rm \
$( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
$( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
test/test_age_restriction.py \
|| die
fi

epatch_user

distutils-r1_python_prepare_all
}

src_compile() {
distutils-r1_src_compile
}

python_test() {
emake test
}

python_install_all() {
dodoc README.txt
doman ${PN}.1

newbashcomp ${PN}.bash-completion ${PN}

insinto /usr/share/zsh/site-functions
newins youtube-dl.zsh _youtube-dl

insinto /usr/share/fish/completions
doins youtube-dl.fish

distutils-r1_python_install_all

rm -r "${ED}"/usr/etc || die
}

0 comments on commit 1ccc01d

Please sign in to comment.