Skip to content

Commit

Permalink
dev-ros/ament_cmake_pytest: bump to 1.0.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Jan 26, 2021
1 parent 60b8a38 commit 1cccbef
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ros/ament_cmake_pytest/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST ament_cmake-1.0.0.tar.gz 63304 BLAKE2B dd0c4bc5b72d9143cfb8ee9caae236a3608981ee8523e879ea9c168d64fd1d0cb84e54679cfc0cfc58ffff34519bb1032afc956c3130c1da8b4f98d60a9191be SHA512 69236015368df29a128eceeb64dd1c683eb32a44188b52120592238f999be8c8c7c5892a36ddcef48b6686bf97eba77e820ca3b8896c64ec1522661fa3ed4fc7
DIST ament_cmake-1.0.1.tar.gz 66465 BLAKE2B cd905b52f4600ccf364ab8d5e4dcf102e1f6034bae7ab020022860fa440ff058a996752cbb0e743b5f66a2b6bc0d1f46cec7c71900be53f035ed8a0642e50b04 SHA512 5f60c933c0ba1eea97f2d0913e19f383e154f26a0625ea4e40c529dd1fa5831109f7cbc0c39a514d37334d61c5d614df0ea546e49ab46202002af09a2adf6288
DIST ament_cmake-1.0.3.tar.gz 67279 BLAKE2B 5a11fd6e8174a47acc2f7524c8aec4ce0b77668525928d722c631b6d874d8d7229a84e5dd084eda834d5afcdf4cc1faf692c3ea4552374b0858c2b60610417e6 SHA512 654a02d8c8130d023d063eff29197ed71e75a1f46c73e3808f5e481ce1b68ff6d0b3002b471bb3ba13a473c4947f4a291cc91cf1aa803906d3a89c78e66eb76a
DIST ament_cmake-1.0.4.tar.gz 67452 BLAKE2B 6c28c06e67e77ca636b1f85a4bb69e1bb856d87a64fbf0cebddbecefc495113aeb001b83b446086233e4330c70b1f420c59efa01f92647539dd8b87a3321fb24 SHA512 f7ec6afd35c314a99f09ccce0568eb9debdcce4ce7494d21a3919328f0b9da062ed3837653e8016f930db75125bf4db85a244f2ce5d26c790e47d1440d1be07e
46 changes: 46 additions & 0 deletions dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{3_6,3_7,3_8} )

inherit cmake python-any-r1

ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_cmake"
SRC_URI=""
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
fi

DESCRIPTION="The ability to run Python tests using pytest in the ament buildsystem"
HOMEPAGE="https://github.com/ament/ament_cmake"

LICENSE="Apache-2.0"
SLOT="0"
if [ "${PV#9999}" != "${PV}" ] ; then
KEYWORDS=""
else
KEYWORDS="~amd64"
fi
IUSE=""

RDEPEND="
dev-ros/ament_cmake_core
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
BDEPEND="
$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"

python_check_deps() {
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}

0 comments on commit 1cccbef

Please sign in to comment.