Skip to content

Commit

Permalink
app-admin/conky: Add patch to build with >=cmake-3.4.0.
Browse files Browse the repository at this point in the history
Also fixes epatch_user which failed in any case, because still
trying to run eautoreconf.
Thanks to Casey Webster for the report and the patches.

Package-Manager: portage-2.2.20.1
  • Loading branch information
billie80 committed Nov 18, 2015
1 parent 175ad62 commit 1cd39e0
Show file tree
Hide file tree
Showing 2 changed files with 32 additions and 3 deletions.
6 changes: 3 additions & 3 deletions app-admin/conky/conky-1.10.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@

EAPI=5

inherit autotools eutils libtool cmake-utils linux-info
inherit eutils cmake-utils linux-info

DESCRIPTION="An advanced, highly configurable system monitor for X"
HOMEPAGE="https://github.com/brndnmtthws/conky"
Expand Down Expand Up @@ -77,10 +77,10 @@ pkg_setup() {

src_prepare() {
epatch "${FILESDIR}/${P}-cmake.patch"
epatch "${FILESDIR}/${P}-includefiles.patch"

# Allow user patches #478482
# Only run autotools if user patched something
epatch_user && eautoreconf || elibtoolize
epatch_user
}

src_configure() {
Expand Down
29 changes: 29 additions & 0 deletions app-admin/conky/files/conky-1.10.0-includefiles.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
--- a/cmake/ConkyPlatformChecks.cmake
+++ b/cmake/ConkyPlatformChecks.cmake
@@ -22,7 +22,7 @@

include(FindPkgConfig)
include(CheckFunctionExists)
-include(CheckIncludeFile)
+include(CheckIncludeFiles)
include(CheckSymbolExists)

# Check for some headers
@@ -119,7 +119,7 @@ if(BUILD_HTTP)
endif(BUILD_HTTP)

if(BUILD_NCURSES)
- check_include_file(ncurses.h NCURSES_H)
+ check_include_files(ncurses.h NCURSES_H)
find_library(NCURSES_LIB NAMES ncurses)
if(NOT NCURSES_H OR NOT NCURSES_LIB)
message(FATAL_ERROR "Unable to find ncurses library")
@@ -167,7 +167,7 @@ endif(BUILD_PORT_MONITORS)

# Check for iconv
if(BUILD_ICONV)
- check_include_file(iconv.h HAVE_ICONV_H)
+ check_include_files(iconv.h HAVE_ICONV_H)
find_library(ICONV_LIBRARY NAMES iconv)
if(NOT ICONV_LIBRARY)
# maybe iconv() is provided by libc

0 comments on commit 1cd39e0

Please sign in to comment.