Skip to content

Commit

Permalink
games-emulation/melonds: bump to 0.9.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Mar 8, 2022
1 parent 6053f73 commit 1ce9e1f
Show file tree
Hide file tree
Showing 2 changed files with 89 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/melonds/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST melonDS-0.9.3.tar.gz 2241325 BLAKE2B 0ea7fbcce039a60a0553ae45d11f0b1550bfec2300faf1c99c3ee531bd5949c7293bec187fbf53e400bbb6280df29db141b2d1bcb294a8abf2eabb71993db686 SHA512 37f26f3a9784873ce1664645cea70049725367f5fe62f7c58842ebd5da2c73ffe423695dddb0ffd444bdf59df2a3fcd778cdf95b2bb083014b961fed282953f5
DIST melonDS-0.9.4.tar.gz 2330626 BLAKE2B 8da363e0345ede978973d29b58c50cd79df5de999abb098a61195d084aed9584273d2a193f8a194642632c4458e3b9bbe11818ae489e1994bb5befa1e1ecf1b2 SHA512 86bb046e180443fe07b27208d08515b0303d3cdb29acad7950d30a55f7baf32c41a4c9ce2f7a681d590e83addc56eb5857e3c7aca5bbfea9b5abe4ce63bdc278
88 changes: 88 additions & 0 deletions games-emulation/melonds/melonds-0.9.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,88 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# NOTICE:
# melonds bundles teakra, its upstream haven't had a release since 2020

EAPI=8

MY_PN="melonDS"
MY_P="${MY_PN}-${PV}"

inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg

DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="
http://melonds.kuribo64.net
https://github.com/Arisotura/melonDS
"

if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
else
SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/${MY_P}"
fi

IUSE="+jit +opengl"
LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
SLOT="0"

DEPEND="
app-arch/libarchive
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
media-libs/libsdl2[sound,video]
net-libs/libpcap
net-libs/libslirp
opengl? ( media-libs/libepoxy )
"
RDEPEND="${DEPEND}"

# used for JIT recompiler
QA_EXECSTACK="usr/bin/melonDS"

DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="You need the following files in order to run melonDS:
- bios7.bin
- bios9.bin
- firmware.bin
- romlist.bin
Place them in ~/.config/melonDS
Those files can be found somewhere on the Internet ;-)"

src_prepare() {
cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DENABLE_JIT=$(usex jit)
-DENABLE_OGLRENDERER=$(usex opengl)
)
cmake_src_configure
}

src_compile() {
tc-export AR
cmake_src_compile
}

src_install() {
# install teakra
dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"

cmake_src_install

readme.gentoo_create_doc
}

pkg_postinst() {
xdg_pkg_postinst

readme.gentoo_print_elog
}

0 comments on commit 1ce9e1f

Please sign in to comment.