Skip to content

Commit

Permalink
app-editors/nedit: fix sed to use pipes
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/711408
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Amy Liffey <[email protected]>
  • Loading branch information
Amynka committed Mar 22, 2020
1 parent 196ea7e commit 1d2ca24
Showing 1 changed file with 8 additions and 8 deletions.
16 changes: 8 additions & 8 deletions app-editors/nedit/nedit-5.7.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand Down Expand Up @@ -35,16 +35,16 @@ src_prepare() {
#respecting LDFLAGS, bug #208189
default
sed \
-e "s:bin/:${EPREFIX}/bin/:g" \
-e "s|bin/|${EPREFIX}/bin/|g" \
-i Makefile source/preferences.c source/help_data.h source/nedit.c Xlt/Makefile || die
sed \
-e "s:nc:neditc:g" -i doc/nc.pod || die
sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" -e "s:check_tif_rule::" \
-e "s|nc|neditc|g" -i doc/nc.pod || die
sed -i -e "s|CFLAGS=-O|CFLAGS=${CFLAGS}|" -e "s|check_tif_rule||" \
makefiles/Makefile.linux || die
sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" \
-e "s:MOTIFDIR=/usr/local:MOTIFDIR=${EPREFIX}/usr:" \
-e "s:-lX11:-lX11 -lXmu -liconv:" \
-e "s:check_tif_rule::" \
sed -i -e "s|CFLAGS=-O|CFLAGS=${CFLAGS}|" \
-e "s|MOTIFDIR=/usr/local|MOTIFDIR=${EPREFIX}/usr|" \
-e "s|-lX11|-lX11 -lXmu -liconv|" \
-e "s|check_tif_rule||" \
makefiles/Makefile.macosx || die
}

Expand Down

0 comments on commit 1d2ca24

Please sign in to comment.