forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-i18n/man-pages-de: Bump to version 1.13 (bug #580382).
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Jun 16, 2016
1 parent
b2075ae
commit 1d337b7
Showing
2 changed files
with
54 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST manpages-de-1.11.tar.xz 1459316 SHA256 ec3dae3d8287dad8aa834fdf86bb4621476376a3ce2576ca7a944c0830845bbe SHA512 3559ae8f073cefbbf9aba34862edfe947847d49cb22c49c71b851059db58aa27ad5f42a1b112554082f0aba72256f16d181fdf0d39780c3ac5a841d5990f9b80 WHIRLPOOL cbc2d5513f64250da22670162ab6b2d67c0d2ed3a5498b634325485f9d1f409f03721a373427f80f71098f9eb6c594ffce46df9f6ba0f3540b6761e004d7e545 | ||
DIST manpages-de-1.12.tar.xz 1475896 SHA256 ad7e49205fdc438eccf69823f406eb5ea6d5fb562a89b6ccac24a07f92b0bb77 SHA512 dd2873e4f72ec1d3c634b95c6b8a843a907ebdf9c79efb74ae333a1ac32003d403dd4e4fa346a6902a9397c06b4dc643a8bed73c90cab522d146f31253249c1d WHIRLPOOL cc3957ec918fa6fc86bda6148c5c7071dd7fe3a8a7cd33413e636a38f1c5d007e24333f680f843ed14d95f8620998d3097ede5aefaca5592cc28d8d591ffb817 | ||
DIST manpages-de-1.13.tar.xz 1487316 SHA256 d8e278055008ffb11e662fed10aa5b9200caa963ebac41697f38d4f2e9641fff SHA512 ba7c95c83550318c5453bc45c78d162aa83c5d95802c539d62b4e85cc432d20dcace5ab8482f496eca6c50728497a71888f1274df64344a99d6370a256c9e20c WHIRLPOOL fffc6fcb65662dd740253e45bcee00d0539332503392f198db0abd086feaeef5b43f48e303e060fd9d2669ed20d611ac5ba34618884e5549f2f82854af008d5e | ||
DIST manpages-de-1.7.tar.xz 1300384 SHA256 7bb014f4ffdc7a303791bb0ee672d901348babcb4c23002cecd3fc145831728a SHA512 d70f25daf10e233358b705c06a7c9e123fffc492429b4b9e1717c5db3a47d92fefb5e628fc75056306bc8bf0da7146aabd2c80a77cb50a430d2e11d6ce9712e0 WHIRLPOOL d8198220f4998e2550166a4b79434c4c1031c1e320b4b858dbf1468c1b1f19aa1d6a02816acd470191546dd5b08b4d1fff4fe612652866db932ee5b4e3dae33a |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit autotools | ||
|
||
MY_P="${PN/-/}-${PV}" | ||
|
||
DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations" | ||
HOMEPAGE="http://alioth.debian.org/projects/manpages-de/" | ||
SRC_URI="http://manpages-de.alioth.debian.org/downloads/${MY_P}.tar.xz" | ||
|
||
LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86" | ||
IUSE="" | ||
|
||
RDEPEND="virtual/man" | ||
DEPEND="app-text/po4a" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-1.3-bzip2.patch" | ||
) | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
src_prepare() { | ||
default | ||
|
||
# Use the same compression as every other manpage | ||
local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2} | ||
if [[ ${PORTAGE_COMPRESS+set} == "set" ]] ; then | ||
PORTAGE_COMPRESS_LOCAL="#" | ||
fi | ||
if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then | ||
case ${PORTAGE_COMPRESS_LOCAL} in | ||
bzip2|gzip) local PORTAGE_COMPRESS_FLAGS_LOCAL="-9" | ||
;; | ||
esac | ||
fi | ||
sed -i -e "s/gzip --best/${PORTAGE_COMPRESS_LOCAL} ${PORTAGE_COMPRESS_FLAGS_LOCAL}/"\ | ||
po/man{1,2,3,4,5,6,7,8}/Makefile.in po/common.mk || die | ||
eautoreconf | ||
} | ||
|
||
src_compile() { :; } | ||
|
||
src_install() { | ||
emake mandir="${ED}"/usr/share/man install | ||
dodoc CHANGES README | ||
} |