Skip to content

Commit

Permalink
media-libs/sdl2-ttf: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
Michael Sterrett committed Jan 4, 2016
1 parent ce85baf commit 1d3c3d9
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/sdl2-ttf/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST SDL2_ttf-2.0.12.tar.gz 5517665 SHA256 8728605443ea1cca5cad501dc34dc0cb15135d1e575551da6d151d213d356f6e SHA512 2dfd7d9a87d86b0446e52c78dcf4c45dba747256ff9cb4cc010818eac725410f5a1a781e6695ca0bcead756c70519d8d5b4df6c1b2935085e0356d9b4d7844fa WHIRLPOOL 7b3457925237f741bdcb1b6b00aa0463f33bde4c8886f03de4cc20885bffadfe3759fb31852dfee1ced06e0e494ec639f0a6a0f415520d9998683b81d010836b
DIST SDL2_ttf-2.0.13.tar.gz 4152978 SHA256 25ddad0302e7d74ce16a770974930cefbdcf67499ca7d40ce7a6bd7de6022fdf SHA512 24f7d77c7d46be3c8236d6edde42f40c97c778e2fdb5d7923f1ec473ce19039c382843afe6de79f04c014d3f854cdf912cdfe1e0cf803a2fd246fd4c65360c6b WHIRLPOOL 52cc6db07d049c6b35f5f68cbc9ed9e3622052a014e1b86ccc0a4b7daa1058a9b8e0f1ca5a42e7ddace0acc4978c4277133611571b1f3a543f048714a615f949
38 changes: 38 additions & 0 deletions media-libs/sdl2-ttf/sdl2-ttf-2.0.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit autotools eutils multilib-minimal

MY_P=SDL2_ttf-${PV}
DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
HOMEPAGE="http://www.libsdl.org/projects/SDL_ttf/"
SRC_URI="http://www.libsdl.org/projects/SDL_ttf/release/${MY_P}.tar.gz"

LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs X"

RDEPEND="X? ( >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] )
>=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]
>=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]"
DEPEND=${RDEPEND}

S=${WORKDIR}/${MY_P}

multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable static-libs static) \
$(use_with X x)
}

multilib_src_install() {
emake DESTDIR="${D}" install
}

multilib_src_install_all() {
dodoc {CHANGES,README}.txt
prune_libtool_files
}

0 comments on commit 1d3c3d9

Please sign in to comment.