Skip to content

Commit

Permalink
app-office/scribus: fixed one boost issue in 1.6.1-r1
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/932492
Signed-off-by: Miroslav Šulc <[email protected]>
  • Loading branch information
fordfrog committed Jun 3, 2024
1 parent 06eab0b commit 1d3dda3
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
39 changes: 39 additions & 0 deletions app-office/scribus/files/scribus-1.6.1-boost-1.85.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
From 3e80b387a226f1abac2bcce6e4300467c189d264 Mon Sep 17 00:00:00 2001
From: Jean Ghali <[email protected]>
Date: Sat, 1 Jun 2024 22:04:13 +0000
Subject: [PATCH] #17229: scribus fails to compile with boost 1.85.0

git-svn-id: svn://scribus.net/branches/Version16x/Scribus@26170 11d20701-8431-0410-a711-e3c959e3b870
--- a/scribus/third_party/lib2geom/point.h
+++ b/scribus/third_party/lib2geom/point.h
@@ -121,10 +121,14 @@ class Point {

Point &operator*=(Matrix const &m);

- inline int operator == (const Point &in_pnt) {
+ inline bool operator==(const Point &in_pnt) const {
return ((_pt[X] == in_pnt[X]) && (_pt[Y] == in_pnt[Y]));
}

+ inline bool operator!=(const Point &in_pnt) const {
+ return ((_pt[X] != in_pnt[X]) || (_pt[Y] != in_pnt[Y]));
+ }
+
friend inline std::ostream &operator<< (std::ostream &out_file, const Geom::Point &in_pnt);
};

@@ -144,14 +148,6 @@ inline Point operator^(Point const &a, Point const &b) {
return ret;
}

-//IMPL: boost::EqualityComparableConcept
-inline bool operator==(Point const &a, Point const &b) {
- return (a[X] == b[X]) && (a[Y] == b[Y]);
-}
-inline bool operator!=(Point const &a, Point const &b) {
- return (a[X] != b[X]) || (a[Y] != b[Y]);
-}
-
/** This is a lexicographical ordering for points. It is remarkably useful for sweepline algorithms*/
inline bool operator<=(Point const &a, Point const &b) {
return ( ( a[Y] < b[Y] ) ||
1 change: 1 addition & 0 deletions app-office/scribus/scribus-1.6.1-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -78,6 +78,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.7.0-fix-icon-version.patch
"${FILESDIR}"/${PN}-1.6.1-poppler-24.03.patch
"${FILESDIR}"/${PN}-1.6.1-poppler-24.05.patch
"${FILESDIR}"/${PN}-1.6.1-boost-1.85.patch
)

src_prepare() {
Expand Down

0 comments on commit 1d3dda3

Please sign in to comment.