Skip to content

Commit

Permalink
dev-util/ROPgadget: new ebuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Mario Haustein <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
hamarituc authored and thesamesam committed Apr 5, 2022
1 parent e26554a commit 1d483db
Show file tree
Hide file tree
Showing 4 changed files with 93 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/ROPgadget/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST ROPgadget-6.6.tar.gz 9349424 BLAKE2B b1f1e5fbc76329f64122e65161ab188e9f7260c4e43d5e92e0e43cd4ebbf27ae281c32bd49790a363ff1d10360a1cda1846310054c249ab40279063a735654e6 SHA512 bf636a264975c95676e5bb6223d0cf04885699eeaf691c6c93a1ac8c1bc44f95323207660a57a58f44163f8c07156567daa73755b35a13cff5d27aee01ec4fb6
36 changes: 36 additions & 0 deletions dev-util/ROPgadget/ROPgadget-6.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite"

inherit distutils-r1

DESCRIPTION="Search for gadgets in binaries to facilitate your ROP exploitation"
HOMEPAGE="http://shell-storm.org/project/ROPgadget/"

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/JonathanSalwan/ROPgadget"
else
SRC_URI="https://github.com/JonathanSalwan/ROPgadget/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="GPL-2"
SLOT="0"

RDEPEND="
${PYTHON_DEPS}
dev-libs/capstone[python,${PYTHON_USEDEP}]
"

S="${WORKDIR}"/ROPgadget-${PV}

src_test() {
pushd test-suite-binaries || die
./test.sh || die
popd || die
}
36 changes: 36 additions & 0 deletions dev-util/ROPgadget/ROPgadget-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite"

inherit distutils-r1

DESCRIPTION="Search for gadgets in binaries to facilitate your ROP exploitation"
HOMEPAGE="http://shell-storm.org/project/ROPgadget/"

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/JonathanSalwan/ROPgadget"
else
SRC_URI="https://github.com/JonathanSalwan/ROPgadget/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="GPL-2"
SLOT="0"

RDEPEND="
${PYTHON_DEPS}
dev-libs/capstone[python,${PYTHON_USEDEP}]
"

S="${WORKDIR}"/ROPgadget-${PV}

src_test() {
pushd test-suite-binaries || die
./test.sh || die
popd || die
}
20 changes: 20 additions & 0 deletions dev-util/ROPgadget/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person" proxied="yes">
<email>[email protected]</email>
<name>Mario Haustein</name>
</maintainer>
<maintainer type="person">
<email>[email protected]</email>
<name>Sam James</name>
</maintainer>
<longdescription>
This tool lets you search your gadgets on your binaries to facilitate
your ROP exploitation. ROPgadget supports ELF, PE and Mach-O format on
x86, x64, ARM, ARM64, PowerPC, SPARC and MIPS architectures.
</longdescription>
<upstream>
<remote-id type="github">JonathanSalwan/ROPgadget</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 1d483db

Please sign in to comment.