Skip to content

Commit

Permalink
dev-python/attrs: suppress too_slow health check on test_recurse_prop…
Browse files Browse the repository at this point in the history
…erty

Bug: https://bugs.gentoo.org/608570
Package-Manager: Portage-2.3.3_p56, Repoman-2.3.1_p49
  • Loading branch information
floppym committed Feb 19, 2017
1 parent eb36e07 commit 1d56d28
Show file tree
Hide file tree
Showing 2 changed files with 25 additions and 0 deletions.
4 changes: 4 additions & 0 deletions dev-python/attrs/attrs-16.3.0-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -29,6 +29,10 @@ DEPEND="${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
)"

PATCHES=(
"${FILESDIR}"/test_funcs-too-slow.patch
)

python_test() {
py.test -v -v || die
}
21 changes: 21 additions & 0 deletions dev-python/attrs/files/test_funcs-too-slow.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
diff --git a/tests/test_funcs.py b/tests/test_funcs.py
index 36969c7..00da655 100644
--- a/tests/test_funcs.py
+++ b/tests/test_funcs.py
@@ -8,7 +8,7 @@ from collections import OrderedDict, Sequence, Mapping

import pytest

-from hypothesis import assume, given, strategies as st
+from hypothesis import assume, given, strategies as st, settings, HealthCheck

from .utils import simple_classes, nested_classes

@@ -57,6 +57,7 @@ class TestAsDict(object):
), dict_factory=dict_class)

@given(nested_classes, st.sampled_from(MAPPING_TYPES))
+ @settings(suppress_health_check=[HealthCheck.too_slow])
def test_recurse_property(self, cls, dict_class):
"""
Property tests for recursive asdict.

0 comments on commit 1d56d28

Please sign in to comment.