Skip to content

Commit

Permalink
media-video/syncplay: add live version.
Browse files Browse the repository at this point in the history
Closes: gentoo#4787
  • Loading branch information
soredake authored and monsieurp committed May 30, 2017
1 parent dd65ea5 commit 1d5d25a
Showing 1 changed file with 60 additions and 0 deletions.
60 changes: 60 additions & 0 deletions media-video/syncplay/syncplay-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit git-r3 python-r1

MY_PV=${PV/_rc/-RC}

DESCRIPTION="Client/server to synchronize media playback"
HOMEPAGE="http://syncplay.pl"
EGIT_REPO_URI="https://github.com/Syncplay/${PN}.git"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="+client +server gui vlc"
REQUIRED_USE="vlc? ( client )
gui? ( client )
${PYTHON_REQUIRED_USE}"

DEPEND=""
RDEPEND="${PYTHON_DEPS}
|| (
>=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
dev-python/twisted-core[${PYTHON_USEDEP}]
)
gui? ( dev-python/pyside[${PYTHON_USEDEP}] )
vlc? ( media-video/vlc[lua] )"

S="${WORKDIR}/${PN}-${MY_PV}"

src_prepare() {
default
if ! use gui; then
sed -i 's/"noGui": False,/"noGui": True,/' \
syncplay/ui/ConfigurationGetter.py \
|| die "Failed to patch ConfigurationGetter.py"
fi
}

src_compile() {
:
}

src_install() {
local MY_MAKEOPTS=( DESTDIR="${D}" PREFIX=/usr )
use client && \
emake "${MY_MAKEOPTS[@]}" VLC_SUPPORT=$(usex vlc true false) install-client
use server && \
emake "${MY_MAKEOPTS[@]}" install-server
}

pkg_postinst() {
if use client; then
einfo "Syncplay supports the following players:"
einfo "media-video/mpv, media-video/mplayer2, media-video/vlc"
fi
}

0 comments on commit 1d5d25a

Please sign in to comment.