Skip to content

Commit

Permalink
dev-perl/Crypt-Cracklib: -r bump for EAPI7 and fixes
Browse files Browse the repository at this point in the history
- EAPI7
- Expand dependencies better
- Migrade "sed" hackery to a patch
- Rework existing patch into git format
- Unconditionally patch out bad tests
- Ensure CFLAGS passed through to make

Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Jun 30, 2020
1 parent 888a73c commit 1d79ac5
Show file tree
Hide file tree
Showing 3 changed files with 85 additions and 0 deletions.
39 changes: 39 additions & 0 deletions dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.700.0-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIST_AUTHOR=DANIEL
DIST_VERSION=1.7
inherit perl-module

DESCRIPTION="Perl interface to Alec Muffett's Cracklib"

SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="sys-libs/cracklib"
DEPEND="${RDEPEND}"
BDEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.420.0
test? (
>=virtual/perl-Test-Simple-0.470.0
)
"

PATCHES=(
"${FILESDIR}/${PN}-1.7-CFLAGS-1.patch"
"${FILESDIR}/${PN}-1.7-no-dot-inc.patch"
)
PERL_RM_FILES=(
t/pod-coverage.t
t/pod.t
)
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}
25 changes: 25 additions & 0 deletions dev-perl/Crypt-Cracklib/files/Crypt-Cracklib-1.7-CFLAGS-1.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
From 160ea833ef64916906c9334f7da12db3208293eb Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <[email protected]>
Date: Wed, 16 Oct 2019 17:00:25 +1300
Subject: Avoid clobbering CFLAGS in Makefile.pl

Bug: https://bugs.gentoo.org/658000
---
Makefile.PL | 1 -
1 file changed, 1 deletion(-)

diff --git a/Makefile.PL b/Makefile.PL
index 34f1008..6ede3a6 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -15,7 +15,6 @@ test_requires 'Test::More' => '0.47';
requires_external_cc();

cc_lib_links('crack');
-cc_optimize_flags('-g -Wall -Werror');

auto_install();
WriteAll();
--
2.27.0

21 changes: 21 additions & 0 deletions dev-perl/Crypt-Cracklib/files/Crypt-Cracklib-1.7-no-dot-inc.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
From 8dd70878d095fa0b35b81ee6e21c2b1fc010b41b Mon Sep 17 00:00:00 2001
From: Kent Fredric <[email protected]>
Date: Wed, 1 Jul 2020 01:23:46 +1200
Subject: Include '.' in @INC for perl 5.26+

---
Makefile.PL | 1 +
1 file changed, 1 insertion(+)

diff --git a/Makefile.PL b/Makefile.PL
index 6ede3a6..d793c3b 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,3 +1,4 @@
+use lib '.';
use inc::Module::Install;

name('Crypt-Cracklib');
--
2.27.0

0 comments on commit 1d79ac5

Please sign in to comment.