Skip to content

Commit

Permalink
dev-php/PEAR-Crypt_GPG: Version bump for 1.6.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
Brian Evans committed Jun 6, 2018
1 parent 6c92b92 commit 1d806ab
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/PEAR-Crypt_GPG/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Crypt_GPG-1.6.2.tgz 346709 BLAKE2B abced2fe8c909f06690c38884506ce03df4c5ef3ef460aafce65ea9405c6974f8af320fd5a07a7967b45421a9a67aa27026c28ef7eb1402ffefba527007a33ae SHA512 9d954d96b4e461c75f79ce9bc701d062e3f19671690228e6e0ce5265733ac1de9c06520f9f750348f3c37f01ccb79720574b2d2f371e69c8a25ae6e1bc18aabd
DIST Crypt_GPG-1.6.3.tgz 346999 BLAKE2B 8402ef382a6393972a3fda7370fbd37dec19d0ebabb6b316d35783538dbc01746476977d7dc3da487876201cd678964d9572dc67a43911319b1b614004a3c909 SHA512 f1ad2560a43a1e8f5a33269bc4ae4067e19e5325fdbd8d2fc55f6cb8aad89258df45fbecedd93a21749f33024c819f07399580b1a4760f5740f26043109dc396
46 changes: 46 additions & 0 deletions dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_PN="${PN/PEAR-/}"
MY_PV="${PV/_/}"
MY_P="${MY_PN}-${MY_PV}"

DESCRIPTION="PHP interface to the GNU Privacy Guard (GnuPG)"
HOMEPAGE="http://pear.php.net/package/${MY_PN}"
SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="test"

RDEPEND="app-crypt/gnupg
dev-lang/php:*[posix,unicode]
dev-php/PEAR-Console_CommandLine
dev-php/PEAR-Exception"
BDEPEND="test? ( ${RDEPEND} dev-php/phpunit )"

S="${WORKDIR}/${MY_P}"

src_prepare() {
default
sed -i "s|@bin-dir@|${EPREFIX}/usr/bin|" Crypt/GPG/Engine.php || die
sed -i "s|@package-name@|${MY_PN}|" Crypt/GPG/PinEntry.php || die
sed -i "s|@data-dir@|${EPREFIX}/usr/share|" Crypt/GPG/PinEntry.php || die
}

src_install() {
dodoc README.md
dobin scripts/crypt-gpg-pinentry

insinto "/usr/share/${MY_PN}"
doins -r data

insinto /usr/share/php
doins -r Crypt
}

src_test() {
phpunit tests/ || die "test suite failed"
}

0 comments on commit 1d806ab

Please sign in to comment.