Skip to content

Commit

Permalink
sys-fs/vhba: Bump to 20190831
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Sep 1, 2019
1 parent 99bd660 commit 1de9b41
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/vhba/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST vhba-module-20190410.tar.bz2 15741 BLAKE2B 6d513877c771b1c4c5805231cf8bb13333d29dd3c6de7d91879ef1898fdc424df026b0835a772f398dcdc7d8900db462164a40e46c9b66b38ed70f5b5f6a0e7e SHA512 e4b30bea8464d8ac24fd2fddca9d41052af2f5b3dc9e054ead47991bff41366be377600075627c40261722c88c20ed2eaf65fa7afb34690ef09a6f4ea6f9351f
DIST vhba-module-20190827.tar.bz2 15570 BLAKE2B 54a50f14659e388c0d53edce842633a3d85bae66483d27e458a83fcc7c547a804e83d34bba0e9a11a0b7e4e533f78c7014ac8e1235a83a7dc6aa13671cb9a823 SHA512 e84ffbbace9964b5fda844d3dd5201ae969ca017886a709d814670a371631376ebb2b1f05775c14ace43e84ed7fc0340638e485ac2a386db530cc25a9fa6e534
DIST vhba-module-20190831.tar.bz2 15570 BLAKE2B 202f28a0729eddce907f5fc46f99a52b116948a376c0f2aaab3b9340f88fc248151c3ec592f2f60e52a07eeed4f551d6f270b4464605bce9df4badf9fa8ed322 SHA512 f43cb9b5730c4d634b58d3dd204610dbc86fdc520d4cfee6c9efbae3bb2acb88f5663e5fbd2b11b5ef9e3b6ad7d4dd0ecf9728dc36ac0b492bd06e0806223591
51 changes: 51 additions & 0 deletions sys-fs/vhba/vhba-20190831.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit eutils linux-mod udev

MY_P=vhba-module-${PV}
DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
HOMEPAGE="https://cdemu.sourceforge.io"
SRC_URI="https://download.sourceforge.net/cdemu/vhba-module/${MY_P}.tar.bz2"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="virtual/udev"
DEPEND="${RDEPEND}
virtual/pkgconfig"

S=${WORKDIR}/${MY_P}
MODULE_NAMES="vhba(block:${S})"
BUILD_TARGETS=modules

pkg_setup() {
CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
check_extra_config
BUILD_PARAMS="KDIR=${KV_OUT_DIR}"
linux-mod_pkg_setup
}

src_prepare() {
# Avoid -Werror problems
sed -i -e '/ccflags/s/-Werror/-Wall/' Makefile || die "sed failed"

eapply_user
}

src_install() {
dodoc AUTHORS ChangeLog README
linux-mod_src_install

einfo "Generating udev rules ..."
dodir "$(get_udevdir)"/rules.d
cat > "${D}$(get_udevdir)"/rules.d/69-vhba.rules <<-EOF || die
# do not edit this file, it will be overwritten on update
#
KERNEL=="vhba_ctl", SUBSYSTEM=="misc", TAG+="uaccess"
EOF
}

0 comments on commit 1de9b41

Please sign in to comment.