Skip to content

Commit

Permalink
media-libs/gstreamer: bump to 1.12.4 for upstream bug fixes
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
leio committed Jan 27, 2018
1 parent 4d996b0 commit 1e0ec0b
Show file tree
Hide file tree
Showing 2 changed files with 109 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/gstreamer/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gstreamer-0.10.36.tar.xz 3025876 BLAKE2B f0f70f483e8ccb2a294fb3bc8b51aac089f5e76522249b64e3e60e7b488a9e03b9300617e2c137bdcc0e3e61668b7b203e899f270f004e2dfcee0927fa7dfc3c SHA512 7468abb578398681d2adb0e9bbc9ee8ae25aaef72369d45a66ada6c67d1759afdce606cb32e68d9e30ae813196bdfef3d4d33202bc77839cc1fbf5fc436c1bd8
DIST gstreamer-1.12.3.tar.xz 3175480 BLAKE2B e42b908b6fef2be5d4a0ad435cab5760a5e73e6f09afa0fd0993dd84d01f956b6437beb367082002e875307970f3b4b3fcb8735f7f69836da0ba76ed186e42db SHA512 fceeeca4314aead7ff358db3474bd6fe1eef70f745a6ba20505da6c0caaea6ea6317246dc66c23edab396ca811a610c52fa930f8f99c701241ae7f15857aa2b0
DIST gstreamer-1.12.4.tar.xz 3177208 BLAKE2B cb859503edbe09cebbbfa70cb4edc5d433bbaa5b299e05921d30e6096f8765e17d449c45bd7d5ea3e4603ae46d337d4e3291b1d0456c7b72a7ebb41faad9e73a SHA512 849aa4ddf8ef465f2915e05d36fc0c31c2e31ae28be2fa38f8069a64a91b7347020fac5b881b7f3ee54c2198c3596138d49f27b09f258303834164a5d68b38a2
108 changes: 108 additions & 0 deletions media-libs/gstreamer/gstreamer-1.12.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,108 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit bash-completion-r1 eutils multilib-minimal pax-utils

DESCRIPTION="Open source multimedia framework"
HOMEPAGE="https://gstreamer.freedesktop.org/"
SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"

LICENSE="LGPL-2+"
SLOT="1.0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="+caps +introspection nls +orc test unwind"

RDEPEND="
>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
unwind? (
>=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
dev-libs/elfutils[${MULTILIB_USEDEP}]
)
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.12
sys-devel/bison
sys-devel/flex
>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
nls? ( sys-devel/gettext )
"
# gtk-doc-am to install API docs

src_configure() {
if [[ ${CHOST} == *-interix* ]] ; then
export ac_cv_lib_dl_dladdr=no
export ac_cv_func_poll=no
fi
if [[ ${CHOST} == powerpc-apple-darwin* ]] ; then
# GCC groks this, but then refers to an implementation (___multi3,
# ___udivti3) that don't exist (at least I can't find it), so force
# this one to be off, such that we use 2x64bit emulation code.
export gst_cv_uint128_t=no
fi

multilib-minimal_src_configure
}

multilib_src_configure() {
local completiondir=$(get_bashcompdir)
# Set 'libexecdir' to ABI-specific location for the library spawns
# helpers from there.
# Disable static archives and examples to speed up build time
# Disable debug, as it only affects -g passing (debugging symbols), this must done through make.conf in gentoo
local myconf=(
--libexecdir="${EPREFIX}"/usr/$(get_libdir)
--disable-debug
--disable-examples
--disable-static
--disable-valgrind
--enable-check
$(use_with unwind)
$(use_with unwind dw)
$(multilib_native_use_enable introspection)
$(use_enable nls)
$(use_enable test tests)
--with-bash-completion-dir="${completiondir%/*}"
--with-package-name="GStreamer ebuild for Gentoo"
--with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer"
)

if use caps ; then
myconf+=( --with-ptp-helper-permissions=capabilities )
else
myconf+=(
--with-ptp-helper-permissions=setuid-root
--with-ptp-helper-setuid-user=nobody
--with-ptp-helper-setuid-group=nobody
)
fi

ECONF_SOURCE="${S}" econf "${myconf[@]}"

if multilib_is_native_abi; then
local x
for x in gst libs plugins; do
ln -s "${S}"/docs/${x}/html docs/${x}/html || die
done
fi
}

multilib_src_install() {
# can't do "default", we want to install docs in multilib_src_install_all
emake DESTDIR="${D}" install

# Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
use orc && pax-mark -m "${ED}usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
}

multilib_src_install_all() {
DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
einstalldocs
prune_libtool_files --modules

# Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}"
}

0 comments on commit 1e0ec0b

Please sign in to comment.