forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
- Loading branch information
Showing
2 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST xdis-3.2.4.tar.gz 127507 SHA256 b311253b97a321ab45625089a729ccbf8bcb1319a8c4c0167b719f81c081543c SHA512 6c9274e10f2a41ab4a173c8ae4462374fc7ab444a589ab572172550d0f5284906f7d9c9cf4a640f163f6012d17f40bc5e1c36e5963f8b6106a9c37e420027a97 WHIRLPOOL 5a0910f04e3d9ec70129d5d3b659fe06034e7a6298692d2a776f2616a8b895a539efa7f96972b2adc6986c2475e697552ea071d33bdd22c60bb1e0fec1950dd4 | ||
DIST xdis-3.3.0.tar.gz 146531 SHA256 32eeb690e9376ad404c1fb18c1f87a09345f9beca31cee1ea8f21dd0f0dcaa07 SHA512 ebd7656c04d5583243eae4442409bde910146f7c5f6b66d58933d4b62818345401523428a596f00cca31a9d6fcd2eea877da57ab3e796dc04c92842456454b3c WHIRLPOOL 784c88d905d47d22a0d0ffb0206f57250f535abce9df6b02be16492c47ffe199ebf5f900eb3199e0be2b89a1d96f951971de5ba8ae33be57013870c1e25f828f | ||
DIST xdis-3.3.1.tar.gz 154152 SHA256 d6e5439269a2abe1fa71ac4cb670ac6dfc9e18a09e0c4acb2f6457f0542d5383 SHA512 93b1a092ae7790e84dfd8dc4128659d48be85c4e00d9914bbd748fad5ec4246bbfc6c19a5c5de366f4bd6d91847dad4ce3c1c3affe8f7608652f2f6e343650e1 WHIRLPOOL d137511eb788cdb43ef5e9165415fb4c7fa4885b9e293d4da7a7c4360e0dad7b00c8ea8df299161cff539a9f7a390d8b39ff6c5697804862259717d54c21f38b | ||
DIST xdis-3.6.0.tar.gz 144766 SHA256 3ea226c201f4be86000b1d09f8585c2de39757325d0b686e3fb14a7dad21c832 SHA512 8b45ccd6976204004f27ee5b1a9da9b29ec0e28f4b462d862be5a1238d3ebd4a5d6f3df5607f3e2f037d80b2d3ae77ec4246ab1aa0671466c1e07e3a65453f3b WHIRLPOOL 156874ee1918eab2e096aa36be0bafd87a32d843d76875bf4eea9366b22616a8aa93610bb959e5ab47f74627f0abc4144a8be345ccf3550858138a860121e793 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Python cross-version byte-code disassembler and marshal routines" | ||
HOMEPAGE="https://github.com/rocky/python-xdis/ https://pypi.python.org/pypi/xdis" | ||
# bad pypi source tarball - test failures | ||
#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz" | ||
SRC_URI="https://github.com/rocky/python-xdis/archive/release-${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}] | ||
dev-python/click[${PYTHON_USEDEP}] | ||
" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
>=dev-python/nose-1.0[${PYTHON_USEDEP}] | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/pytest[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/xdis-3.3.0-remove-pytest-runner-dep.patch" | ||
) | ||
|
||
S="${WORKDIR}/python-xdis-release-${PV}" | ||
|
||
python_test() { | ||
# Need to rm any pyc files to prevent test failures. | ||
rm -R "${S}"/test/__pycache__ | ||
PYTHONPATH="${S}/test:${S}/test_unit:${BUILD_DIR}/lib" \ | ||
esetup.py test || die "Tests failed under ${EPYTHON}" | ||
} |