forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.20.1
- Loading branch information
Michael Palimaka
committed
Sep 24, 2015
1 parent
7fb393a
commit 1e209fd
Showing
3 changed files
with
130 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kate-15.08.0.tar.xz 1759156 SHA256 834bd05c2e565d030cb58e47ae5a1bc0f487242bcca7b8d54de0fd73ace13656 SHA512 ad00616c8c4a2c11264be7959e751d143c9030c20413f9a972bb9c61cd425226803e04b13509761fec4597f3c0b0cb4f013f3d4a81469309f1de45693ec3e4eb WHIRLPOOL 5ffa81557b48769f2b59c62b4c9cae24f271a7fe23bc0c16b60fffdae93029dc7dfa396eaa1a23710797cae16dbc9d54c5dae64ccd9e1f0df35e397ac03f26f2 | ||
DIST kate-15.08.1.tar.xz 1758912 SHA256 3f96756f7f4c6d178d2310a9fd1b63e816348d49cb4d53907e10fc6a29c92b43 SHA512 463e7b57f54305582a3faacbb92499a1fa54684da3a97adb072e6b613589c12eaa0ca7e618dbeea60f57ee31786c2ca1ca23a9f53d11bd986a240113ba124108 WHIRLPOOL 839e25ee5d4ae3fe7c02b3de6c2899bef4339cecff3930dbc810382b27e2e0298c7db9014233c2db5e583f66d46bfbc757517ea5426c7c46eb303df0326652d4 | ||
DIST kate-4.14.3.tar.xz 2766880 SHA256 513d4ae2c36fa6b59caf3b2b685e3ea1167093d16025859cfac90d75617e707d SHA512 0d197bb00fb9a56572e140dd3c50338c90a0cb3bb8ebc78cc0e6d6ab04d6c129537a2ab8076ff9b844e159687c0a73cbacbe678e006b2d86b57285068158e38e WHIRLPOOL bb1c499c55dc768ab936d4a2e2f6ac79ddb28d84c517bfa1ec421fdfbc6f9e727ae5c0e3f1773e3664ad263217c1b89f9c83b51ad0ca6fdee36e23b20fa964d5 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,57 @@ | ||
From c6eee39e8c5185a0c330e3c70c7b1e109c69ac44 Mon Sep 17 00:00:00 2001 | ||
From: Andrew Wilcox <[email protected]> | ||
Date: Sat, 12 Sep 2015 15:31:11 -0500 | ||
Subject: [PATCH] Project plugin: Properly initialise libgit2 | ||
|
||
Fixes bugs #346101, #346102, #345602 | ||
--- | ||
addons/project/kateprojectworker.cpp | 6 ++++++ | ||
1 file changed, 6 insertions(+) | ||
|
||
diff --git a/addons/project/kateprojectworker.cpp b/addons/project/kateprojectworker.cpp | ||
index 847f2b2..5433ee8 100644 | ||
--- a/addons/project/kateprojectworker.cpp | ||
+++ b/addons/project/kateprojectworker.cpp | ||
@@ -276,12 +276,15 @@ QStringList KateProjectWorker::filesFromGit(const QDir &dir, bool recursive) | ||
return 0; | ||
}; | ||
|
||
+ git_libgit2_init(); | ||
+ | ||
if (git_repository_open_ext(&repo, dir.path().toUtf8().data(), 0, NULL)) { | ||
return QStringList(); | ||
} | ||
|
||
if ((working_dir = git_repository_workdir(repo)) == nullptr) { | ||
git_repository_free(repo); | ||
+ git_libgit2_shutdown(); | ||
return files; | ||
} | ||
|
||
@@ -290,6 +293,7 @@ QStringList KateProjectWorker::filesFromGit(const QDir &dir, bool recursive) | ||
|
||
if (git_revparse_single(&root_tree, repo, "HEAD^{tree}")) { | ||
git_repository_free(repo); | ||
+ git_libgit2_shutdown(); | ||
return files; | ||
} | ||
|
||
@@ -299,6 +303,7 @@ QStringList KateProjectWorker::filesFromGit(const QDir &dir, bool recursive) | ||
if (git_object_lookup_bypath(&tree, root_tree, relpath.toUtf8().data(), GIT_OBJ_TREE)) { | ||
git_object_free(root_tree); | ||
git_repository_free(repo); | ||
+ git_libgit2_shutdown(); | ||
return files; | ||
} | ||
} | ||
@@ -311,6 +316,7 @@ QStringList KateProjectWorker::filesFromGit(const QDir &dir, bool recursive) | ||
|
||
git_object_free(root_tree); | ||
git_repository_free(repo); | ||
+ git_libgit2_shutdown(); | ||
return files; | ||
} | ||
|
||
-- | ||
2.5.2 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,72 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
KDE_HANDBOOK="true" | ||
KDE_TEST="true" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Kate is an advanced text editor" | ||
HOMEPAGE="https://www.kde.org/applications/utilities/kate http://kate-editor.org" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+addons" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kactivities) | ||
$(add_frameworks_dep kcodecs) | ||
$(add_frameworks_dep kcompletion) | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep kguiaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep kitemmodels) | ||
$(add_frameworks_dep kitemviews) | ||
$(add_frameworks_dep kjobwidgets) | ||
$(add_frameworks_dep kparts) | ||
$(add_frameworks_dep kservice) | ||
$(add_frameworks_dep ktexteditor) | ||
$(add_frameworks_dep ktextwidgets) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kwindowsystem) | ||
$(add_frameworks_dep kxmlgui) | ||
dev-qt/qtdbus:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtscript:5 | ||
dev-qt/qtwidgets:5 | ||
dev-qt/qtxml:5 | ||
addons? ( | ||
$(add_frameworks_dep kbookmarks) | ||
$(add_frameworks_dep knewstuff) | ||
$(add_frameworks_dep knotifications) | ||
$(add_frameworks_dep kwallet) | ||
$(add_frameworks_dep plasma) | ||
$(add_frameworks_dep threadweaver) | ||
dev-qt/qtsql:5 | ||
>=dev-libs/libgit2-0.22.0:= | ||
) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
PATCHES=( "${FILESDIR}/${P}-initialise-libgit2.patch" ) | ||
|
||
src_prepare() { | ||
kde5_src_prepare | ||
|
||
sed -i -e "/add_subdirectory( kwrite )/d" doc/CMakeLists.txt || die | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_build addons) | ||
-DBUILD_kwrite=FALSE | ||
) | ||
|
||
kde5_src_configure | ||
} |