Skip to content

Commit

Permalink
dev-libs/cppcodec: Initial ebuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
SoapGentoo committed Mar 11, 2018
1 parent 1b359a2 commit 1e3bbc4
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
38 changes: 38 additions & 0 deletions dev-libs/cppcodec/cppcodec-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
inherit cmake-utils

DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
HOMEPAGE="https://github.com/tplgy/cppcodec"

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/tplgy/cppcodec.git"

# Disable pulling in catch
EGIT_SUBMODULES=()
else
SRC_URI="https://github.com/tplgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="GPL-3"
SLOT="0"
IUSE="test"

DEPEND="
test? (
virtual/pkgconfig
>=dev-cpp/catch-2.2.0
)"

src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test)
)
cmake-utils_src_configure
}
12 changes: 12 additions & 0 deletions dev-libs/cppcodec/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>David Seifert</name>
</maintainer>
<upstream>
<remote-id type="github">tplgy/cppcodec</remote-id>
<bugs-to>https://github.com/tplgy/cppcodec/issues</bugs-to>
</upstream>
</pkgmetadata>

0 comments on commit 1e3bbc4

Please sign in to comment.