Skip to content

Commit

Permalink
app-shells/thefuck: Version bump to 3.25 and add proxied maintainer
Browse files Browse the repository at this point in the history
Closes: gentoo#6294
Package-Manager: Portage-2.3.16, Repoman-2.3.6
  • Loading branch information
holgersson32644 authored and SoapGentoo committed Nov 25, 2017
1 parent b602261 commit 1e436f3
Show file tree
Hide file tree
Showing 3 changed files with 50 additions and 1 deletion.
1 change: 1 addition & 0 deletions app-shells/thefuck/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST thefuck-3.24.tar.gz 1360450 SHA256 686867f264ee34d9287814dde0e9ca5debb322deeaf0ac6773ec06f823d7c0b4 SHA512 d4949ea723cf3b080f2fbe269d0cafe3d0266089fa8cc515b3b9376b2004c045be82716cd219741a60a0e99c20575adb92339a879467f709f7ca03dcc71a5c2d WHIRLPOOL 395eb03bf8ec1504909631a7e88e2761d7778742fb52d6fd567ee4c3c1ec9186726550dde23b2234a93064d6317065852236fb83fd4bfcdb733a4d2aa7cee2e8
DIST thefuck-3.25.tar.gz 1362279 BLAKE2B 52b3f1c8756b6981c0528fd77c18256957dd5d628ea37801b9c9abf6114e1cef8af53d9d1dd50fc7c88fad7bd628dc8373aa70dbc6933c07c63b7da31eb5d95a SHA512 c7b215358c09e1fa5e6aae519e7d6c3fd50027b4c72bb1c128786cd2cff707196f2b9b2a23dfed34d841874caab9463791e82c9083f6aac9c90f26d12a4d4598
9 changes: 8 additions & 1 deletion app-shells/thefuck/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<maintainer type="person">
<email>[email protected]</email>
<name>Nils Freydank</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<upstream>
<remote-id type="github">nvbn/thefuck</remote-id>
</upstream>
Expand Down
41 changes: 41 additions & 0 deletions app-shells/thefuck/thefuck-3.25.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python3_{4,5,6} )

inherit distutils-r1

DESCRIPTION="Magnificent app which corrects your previous console command"
HOMEPAGE="https://github.com/nvbn/thefuck"
SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/decorator[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/pyte[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
)"

python_prepare_all() {
sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die

distutils-r1_python_prepare_all
}

python_test() {
py.test || die
}

0 comments on commit 1e436f3

Please sign in to comment.