Skip to content

Commit

Permalink
dev-ruby/slim: add 3.0.6
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
graaff committed Nov 1, 2015
1 parent ae3242b commit 1e52ba8
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/slim/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST slim-2.0.3.gem 80896 SHA256 ba637becab0090feb16923c808ccf92ab42728eb1799e2bed45d7ca2e34e47fc SHA512 b519bde5725f0eae37f0aa5b0eef99f62749ff19ee17fc87291c5cd38c053106aa57fabc0ead05992c3316c509381c5bb30a9ac42b8584f99beb7f3e59c91bdf WHIRLPOOL 331dec490db9a2d145006e57d072a86eb8b0e45c8fad81fd6ab5bea5b3a2da9cac248fa7dce679f67d3c46f95a869b0ffd981f9d7d943518f7025651172946dc
DIST slim-2.1.0.gem 92160 SHA256 de574c991afb2d2b3e081e9d1e4f4e20b339d3b2895b51f7bf022a35a82acd6b SHA512 a092689e62f1189aac9b6657572f76ee9915f1dbfcea7ed90c07386958cbeb6c974d25b7bc85f4cc6887312ab373487618e8dfd8e0f2b9f4dbd0574b0f4b928f WHIRLPOOL a7d141d7c9ce2e88770cc9ffb590465b0d597da1dd3df858a0e0843dc9b182426cc28793df9f56d06f770aff91208433c8fbdef8e5d9780c22edf91d2474989b
DIST slim-3.0.6.gem 96256 SHA256 1315604e79dcf6c89916007ad297e716c35109e19d2d6ce42b5557006138faeb SHA512 06b13f2880752be7e00ee61a86f0d88926b1f0f108b496355a40b30d32101bb777062079b4727eafe7166d404374badb9d2ee50c53dbf4d2206d583c71fb6e7c WHIRLPOOL 4485de92621f7944d74400a561220e1434d0c009cf985864a0169699794028db404ea93d3872e739d49b0c781454e46d85c10d0f5c6b5ba8505c109f1c17362a
45 changes: 45 additions & 0 deletions dev-ruby/slim/slim-3.0.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21"

RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_TASK_DOC="yard"

inherit ruby-fakegem

DESCRIPTION="A template language whose goal is reduce the syntax to the essential parts without becoming cryptic"
HOMEPAGE="http://slim-lang.com/"
LICENSE="MIT"

KEYWORDS="~amd64"
SLOT="0"
IUSE="doc"

ruby_add_rdepend ">=dev-ruby/tilt-1.3.3:* <dev-ruby/tilt-2.1:*
>=dev-ruby/temple-0.7.3:0.7"

ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/redcarpet )"

ruby_add_bdepend "test? ( dev-ruby/sass )"

all_ruby_prepare() {
sed -i -e '/bundler/I s:^:#:' Rakefile || die

# This sinatra code expects tests to be installed but we strip those.
sed -i -e "s/require 'sinatra'/require 'bogussinatra'/" Rakefile || die

# Avoid tests for things we don't have.
sed -i -e '/test_wip_render_with_asciidoc/,/^ end/ s:^:#:' \
-e '/test_render_with_wiki/,/^ end/ s:^:#:' \
-e '/test_render_with_creole/,/^ end/ s:^:#:' \
-e '/test_render_with_org/,/^ end/ s:^:#:' test/core/test_embedded_engines.rb || die
}

each_ruby_prepare() {
sed -i -e '/Open3/ s:ruby:'${RUBY}':' test/core/test_commands.rb || die
}

0 comments on commit 1e52ba8

Please sign in to comment.