Skip to content

Commit

Permalink
net-im/skypeforlinux: version bump to 8.15.0.4
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/647048
Closes: gentoo#7129
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
karolgrudzinski authored and mgorny committed Feb 8, 2018
1 parent e09f23c commit 1e6477e
Show file tree
Hide file tree
Showing 2 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-im/skypeforlinux/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST skypeforlinux_8.11.0.4-1.x86_64.rpm 94517788 BLAKE2B 5cec1184c566822dab55a2e01424400d46c9894fe77c0031c59063359c50b017f485ee1505db961fa4dacce9c1bd2634bbabd88b6b03925c4cff80d7a7d9b408 SHA512 580183fb278b12974e28be10cdb13925048e4692ac12e5f1abab219ede12b0ec8567d49e58e2c3a7b4d4bcfc56e3ec1cb91117c0056d86dca7d9f1e2ec363b3e
DIST skypeforlinux_8.13.0.2-1.x86_64.rpm 102816632 BLAKE2B 402b95a4dfaebf93200f46fb226d907fe99bb42141f629750ec34c97bae576b79953178c21cfb5309e20867a227577998887e063b9aa2a7e4aacfd0c747911e6 SHA512 2628cb5be1d95b838afd2bc51f200e7c2591e5620c45019ff179fb2f8a480dea0f643676ab0cfea5946a1a5d79d0e181b1b1e4c8f7bade60ffe176e5cb8b3795
DIST skypeforlinux_8.14.0.10-1.x86_64.rpm 103063075 BLAKE2B c1d414ffbaa633bc29146c2a8b0e731c575c8c0afc523b487834aef9759981449659aec6720e6a3659f785d7089d9af3f59a959553f87e9007e4dcac9ebb91f4 SHA512 86471e71f2cb0eca0a41f0fc6e9dce6c67d2af898376bb70524a06ac21af4aa18855f1f22493f2fdd0a9753cd3d451228fe8b24661b1abed328a8bf85381f6d0
DIST skypeforlinux_8.15.0.4-1.x86_64.rpm 104944478 BLAKE2B 6a490eb49e1887a6e4aa97c644d840dd5daf085212db431ade92232f354d7f6f707b596055f4fd2b74922c071de7179de7be570dc9fa8c08e536ada8abecc0e2 SHA512 5a70ef2395b9d37b4d6417de9a3211b64f0fc7f6bc92b93abace51da911a79e559d1c4f590f1ee830a56e186a91ab713ee8e3327dfae260635ae9005341fcb1c
116 changes: 116 additions & 0 deletions net-im/skypeforlinux/skypeforlinux-8.15.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,116 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MULTILIB_COMPAT=( abi_x86_64 )

inherit eutils gnome2-utils pax-utils rpm multilib-build xdg-utils

DESCRIPTION="Instant messaging client, with support for audio and video"
HOMEPAGE="https://www.skype.com/"
SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"

LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 -*"
IUSE="pax_kernel"

S="${WORKDIR}"
QA_PREBUILT="*"
RESTRICT="mirror bindist strip" #299368

RDEPEND="
app-crypt/libsecret[${MULTILIB_USEDEP}]
dev-libs/atk[${MULTILIB_USEDEP}]
dev-libs/expat[${MULTILIB_USEDEP}]
dev-libs/glib:2[${MULTILIB_USEDEP}]
dev-libs/nspr[${MULTILIB_USEDEP}]
dev-libs/nss[${MULTILIB_USEDEP}]
gnome-base/gconf:2[${MULTILIB_USEDEP}]
media-libs/alsa-lib[${MULTILIB_USEDEP}]
media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
media-libs/freetype:2[${MULTILIB_USEDEP}]
media-libs/libv4l[${MULTILIB_USEDEP}]
net-print/cups[${MULTILIB_USEDEP}]
sys-apps/dbus[${MULTILIB_USEDEP}]
sys-devel/gcc[cxx]
virtual/ttf-fonts
x11-libs/cairo[${MULTILIB_USEDEP}]
x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
x11-libs/gtk+:2[${MULTILIB_USEDEP}]
x11-libs/libX11[${MULTILIB_USEDEP}]
x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
x11-libs/libXcomposite[${MULTILIB_USEDEP}]
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXdamage[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXrender[${MULTILIB_USEDEP}]
x11-libs/libXtst[${MULTILIB_USEDEP}]
x11-libs/libxcb[${MULTILIB_USEDEP}]
x11-libs/libxkbfile[${MULTILIB_USEDEP}]
x11-libs/pango[${MULTILIB_USEDEP}]"

src_unpack() {
rpm_src_unpack ${A}
}

src_prepare() {
default
sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
-i usr/bin/skypeforlinux || die
sed -e "s!^Exec=/usr/!Exec=${EPREFIX}/opt/!" \
-e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
-e "/^OnlyShowIn=/d" \
-i usr/share/applications/skypeforlinux.desktop || die
}

src_install() {
dodir /opt
cp -a usr/share/skypeforlinux "${D}"/opt || die

into /opt
dobin usr/bin/skypeforlinux

dodoc usr/share/skypeforlinux/*.html
dodoc -r usr/share/doc/skypeforlinux/.
# symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
dosym ${P} usr/share/doc/skypeforlinux

doicon usr/share/pixmaps/skypeforlinux.png

# compat symlink for the autostart desktop file
dosym ../../opt/bin/skypeforlinux usr/bin/skypeforlinux

local res
for res in 16 32 256 512; do
newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
done

domenu usr/share/applications/skypeforlinux.desktop

if use pax_kernel; then
pax-mark -m "${ED%/}"/opt/skypeforlinux/skypeforlinux
pax-mark -m "${ED%/}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
ewarn "You have set USE=pax_kernel meaning that you intend to run"
ewarn "${PN} under a PaX enabled kernel. To do so, we must modify"
ewarn "the ${PN} binary itself and this *may* lead to breakage! If"
ewarn "you suspect that ${PN} is being broken by this modification,"
ewarn "please open a bug."
fi
}

pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
gnome2_icon_cache_update
}

pkg_postrm() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
gnome2_icon_cache_update
}

0 comments on commit 1e6477e

Please sign in to comment.