forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-misc/cmatrix: Fix building against sys-libs/ncurses[tinfo]. Fix s…
…ome horrible QA issues. Package-Manager: portage-2.3.2
- Loading branch information
Jeroen Roovers
committed
Oct 20, 2016
1 parent
b76a7bd
commit 1e87a77
Showing
2 changed files
with
84 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
inherit autotools | ||
|
||
DESCRIPTION="An ncurses based app to show a scrolling screen from the Matrix" | ||
HOMEPAGE="http://www.asty.org/cmatrix" | ||
SRC_URI="http://www.asty.org/${PN}/dist/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86" | ||
IUSE="X" | ||
|
||
DEPEND=" | ||
X? ( x11-apps/mkfontdir ) | ||
sys-libs/ncurses:0=" | ||
|
||
RDEPEND="${DEPEND}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${P}-gentoo.patch | ||
"${FILESDIR}"/${P}-tinfo.patch | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
use X && eapply "${FILESDIR}"/${P}-fontdir.patch | ||
|
||
eautoreconf | ||
} | ||
|
||
src_install() { | ||
dodir /usr/share/consolefonts | ||
dodir /usr/lib/kbd/consolefonts | ||
use X && dodir /usr/share/fonts/misc | ||
|
||
default | ||
} | ||
|
||
pkg_postinst() { | ||
if use X; then | ||
if [[ -d "${ROOT}"usr/share/fonts/misc ]] ; then | ||
einfo ">>> Running mkfontdir on ${ROOT}usr/share/fonts/misc" | ||
mkfontdir "${ROOT}"usr/share/fonts/misc | ||
fi | ||
fi | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
--- a/configure.in | ||
+++ b/configure.in | ||
@@ -8,9 +8,7 @@ | ||
AC_PROG_INSTALL | ||
AC_PROG_MAKE_SET | ||
|
||
-dnl Checks for libraries. | ||
-dnl Replace `main' with a function in -lncurses: | ||
-AC_CHECK_LIB(ncurses, main) | ||
+PKG_PROG_PKG_CONFIG | ||
|
||
dnl Checks for header files. | ||
AC_HEADER_STDC | ||
@@ -26,18 +24,7 @@ | ||
|
||
AC_CHECK_HEADERS(curses.h ncurses.h) | ||
|
||
-CURSES_LIB_NAME="" | ||
-AC_CHECK_LIB(ncurses, tgetent, CURSES_LIB="-lncurses" CURSES_LIB_NAME=ncurses) | ||
- | ||
-if eval "test x$CURSES_LIB_NAME = x" | ||
-then | ||
- AC_CHECK_LIB(curses, tgetent, CURSES_LIB="-lcurses" CURSES_LIB_NAME=curses) | ||
-fi | ||
- | ||
-if eval "test x$CURSES_LIB_NAME = x" | ||
-then | ||
- AC_CHECK_LIB(termcap, tgetent, CURSES_LIB="-ltermcap" CURSES_LIB_NAME=termcap) | ||
-fi | ||
+PKG_CHECK_MODULES(ncurses,ncurses,[LIBS="$LIBS $ncurses_LIBS";CURSES_LIB_NAME=ncurses]) | ||
|
||
if eval "test x$CURSES_LIB_NAME = x" | ||
then |