Skip to content

Commit

Permalink
mail-filter/imapfilter: migrate to lua-single.eclass
Browse files Browse the repository at this point in the history
Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
Marek Szuba committed Oct 14, 2020
1 parent 39fe3d9 commit 1ea529f
Showing 1 changed file with 55 additions and 0 deletions.
55 changes: 55 additions & 0 deletions mail-filter/imapfilter/imapfilter-2.6.16-r100.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

LUA_COMPAT=( lua5-{1..3} )

inherit lua-single toolchain-funcs

DESCRIPTION="An IMAP mail filtering utility"
HOMEPAGE="https://github.com/lefcha/imapfilter"
SRC_URI="https://github.com/lefcha/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"

IUSE="libressl"

REQUIRED_USE="${LUA_REQUIRED_USE}"

RDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
dev-libs/libpcre
${LUA_DEPS}"
DEPEND="${RDEPEND}"

DOCS="AUTHORS NEWS README samples/*"

PATCHES=(
"${FILESDIR}"/${PN}-2.6.16-libressl.patch
)

src_prepare() {
default
sed -i -e "/^PREFIX/s:/usr/local:${EPREFIX}/usr:" \
-e "/^MANDIR/s:man:share/man:" \
-e "/^CFLAGS/s:CFLAGS =:CFLAGS +=:" \
-e "/^CFLAGS/s/-O//" \
src/Makefile || die
}

src_compile() {
emake \
CC="$(tc-getCC)" \
LDFLAGS="${LDFLAGS}" \
INCDIRS=$(lua_get_CFLAGS) \
LIBLUA=$(lua_get_LIBS)
}

src_install() {
default
doman doc/imapfilter.1 doc/imapfilter_config.5
}

0 comments on commit 1ea529f

Please sign in to comment.