forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-software: Version bump to 42.3
Signed-off-by: Matt Turner <[email protected]>
- Loading branch information
Showing
2 changed files
with
103 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gnome-software-42.2.tar.xz 2274824 BLAKE2B 0c971bbe8f7e074ddc23923f14aeca4e95a0c305d016548d69bc51100859dfc30fcfcfbfe88189b6a0e4d2531c8223822aa8f16bee5bba6046266077e7c26eda SHA512 2b231afbedb241b8957fa902c37cd85734cdb8b2071cd32ac75ae2e9e064483fe1e9e8d49f2e6df478fdd01e9c6225a85887ba2af1792a9150b89cea75ef8bb4 | ||
DIST gnome-software-42.3.tar.xz 2275144 BLAKE2B ba9f5e2da24d84e048da0f81dc096273dc28f174fb8ad61dc7e1e82db9d9067c6bc1d17b6095618f8a540c39c7b356534d8f4fc37bde3f6f49b9cfc129873985 SHA512 8adae64b3149145548fc80ba3491e92d47a711341020b8edb53333f07367b0e2d37864940af71a35d980f634e7a1df68e9fde3c56d17c8e482699358c8eba8b7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,102 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit gnome.org gnome2-utils meson virtualx xdg | ||
|
||
DESCRIPTION="Gnome install & update software" | ||
HOMEPAGE="https://wiki.gnome.org/Apps/Software" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="flatpak +firmware gnome gtk-doc sysprof udev" | ||
RESTRICT="test" # See TODO below | ||
|
||
RDEPEND=" | ||
>=dev-libs/appstream-0.14.0:0= | ||
>=x11-libs/gdk-pixbuf-2.32.0:2 | ||
>=dev-libs/libxmlb-0.1.7:= | ||
>=gui-libs/gtk-4.6:4 | ||
>=dev-libs/glib-2.66.0:2 | ||
>=dev-libs/json-glib-1.6.0 | ||
>=net-libs/libsoup-2.52.0:2.4 | ||
>=gui-libs/libadwaita-1.0.1:1 | ||
sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 ) | ||
gnome? ( >=gnome-base/gsettings-desktop-schemas-3.18.0 ) | ||
sys-auth/polkit | ||
firmware? ( >=sys-apps/fwupd-1.5.6 ) | ||
flatpak? ( | ||
>=sys-apps/flatpak-1.9.1 | ||
dev-util/ostree | ||
) | ||
udev? ( dev-libs/libgudev ) | ||
>=gnome-base/gsettings-desktop-schemas-3.11.5 | ||
" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND=" | ||
dev-libs/libxml2:2 | ||
dev-util/gdbus-codegen | ||
>=sys-devel/gettext-0.19.8 | ||
virtual/pkgconfig | ||
gtk-doc? ( | ||
dev-util/gtk-doc | ||
app-text/docbook-xml-dtd:4.3 ) | ||
" | ||
# test? ( dev-util/valgrind ) | ||
|
||
src_prepare() { | ||
default | ||
xdg_environment_reset | ||
|
||
sed -i -e '/install_data.*README\.md.*share\/doc\/gnome-software/d' meson.build || die | ||
# We don't need language packs download support, and it fails tests in 3.34.2 for us (if they are enabled) | ||
sed -i -e '/subdir.*fedora-langpacks/d' plugins/meson.build || die | ||
# Trouble talking to spawned gnome-keyring socket for some reason, even if wrapped in dbus-run-session | ||
# TODO: Investigate; seems to work outside ebuild .. test/emerge | ||
sed -i -e '/g_test_add_func.*gs_auth_secret_func/d' lib/gs-self-test.c || die | ||
} | ||
|
||
src_configure() { | ||
local emesonargs=( | ||
$(meson_use test tests) | ||
$(meson_feature gnome gsettings_desktop_schemas) # Honoring of GNOME date format settings. | ||
-Dman=true | ||
-Dpackagekit=false | ||
# -Dpackagekit_autoremove | ||
-Dpolkit=true | ||
-Deos_updater=false # Endless OS updater | ||
$(meson_use firmware fwupd) | ||
$(meson_use flatpak) | ||
-Dmalcontent=false | ||
-Drpm_ostree=false | ||
$(meson_use udev gudev) | ||
-Dapt=false | ||
-Dsnap=false | ||
-Dexternal_appstream=false | ||
-Dvalgrind=false | ||
$(meson_use gtk-doc gtk_doc) | ||
-Dhardcoded_popular=true | ||
-Ddefault_featured_apps=false # TODO: Will this be beneficial to us with flatpak at least? If enabled, it shows some apps under installed (probably merely due to /usr/share/app-info presence), but launching and removal of them is broken | ||
-Dmogwai=false #TODO? | ||
$(meson_feature sysprof) | ||
-Dprofile='' | ||
-Dsoup2=true | ||
) | ||
meson_src_configure | ||
} | ||
|
||
src_test() { | ||
virtx meson_src_test | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
gnome2_schemas_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_pkg_postrm | ||
gnome2_schemas_update | ||
} |