forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/pymediainfo: version bump to 2.1.9 and add
Python 3.6 support. Use py.test instead of nose in order to easily exclude the new test which requires network access. Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: gentoo#4279
- Loading branch information
Showing
2 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST pymediainfo-2.1.4.tar.gz 420642 SHA256 b4ce090a5bfa24bf5f54a0a16c41ef0c3a0e12d4dae97bdb8b237788664c0136 SHA512 a82bb910ec76e11fb5120c224a804f6db1cef2cd4c6be0e3a5f5905d44594d35bf0abee629ea5092de2dbd7506a8c876735e53b0e2fd837dcadfabe2e8535dbb WHIRLPOOL be3617b6f2b03e404bab89a3d829a7f882bec2e2c61b7dcf00c01d809ca192da07aaed5e0f54723dd3169fb9ad17b76be61ceabc2e06ae1b9f63736254d319a1 | ||
DIST pymediainfo-2.1.5.tar.gz 421120 SHA256 53616f5b87431d7fd0b4c7a2c2592c9071de923c5c0b167f1015905092a86915 SHA512 ef7891bb8e55e11e211f5d7a222176ffea013c4876b2a524ee02af6bcaa3cef272c11e7e39f12790de37f9bc95aa71af049727632092dbaa4c30ea3d149ddf70 WHIRLPOOL 6272df6e234655bc30fe8af811ad644d9062dd5a86837561885144f5a51c6ad931566b9e0fac073c89d99df6b8c82e282655fded66c056315dc10a0b4d30810a | ||
DIST pymediainfo-2.1.9.tar.gz 420111 SHA256 ca3620c3a99052a687c3b625fdddd27693512814808c7b923709bb397930eb0d SHA512 8bc3abe3146f57cb33b5a3bdd1d902a9ef82211b0755d70d9d33601c6eaeaf397b2dd2428edd72a1541cba3cad5f2a414fc1802cf2c5529ada747c9f3b8f280c WHIRLPOOL e6b220061892e064de7506be596023271c07e7d1d47fd093782123fd27e284a1cceed403b876910fca1f27a044d786c202126507d0de8df9d59ea42eef496435 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="A wrapper around the mediainfo library" | ||
HOMEPAGE="https://github.com/sbraz/pymediainfo" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="doc test" | ||
|
||
RDEPEND="media-libs/libmediainfo" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] ) | ||
test? ( | ||
${RDEPEND} | ||
dev-python/pytest[${PYTHON_USEDEP}] | ||
dev-python/pytest-runner[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
python_compile_all() { | ||
use doc && esetup.py build_sphinx | ||
} | ||
|
||
python_test() { | ||
# requires network access | ||
py.test tests/test.py -k "not MediaInfoURLTest" \ | ||
|| die "tests failed with ${EPYTHON}" | ||
} | ||
|
||
python_install_all() { | ||
use doc && local HTML_DOCS=( docs/_build/html/. ) | ||
distutils-r1_python_install_all | ||
} |