Skip to content

Commit

Permalink
dev-libs/liberasurecode: fixing qa issues for bug 558892
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
prometheanfire committed Aug 27, 2015
1 parent 57b3567 commit 1edf0ff
Showing 1 changed file with 38 additions and 0 deletions.
38 changes: 38 additions & 0 deletions dev-libs/liberasurecode/liberasurecode-1.0.8-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit autotools multilib toolchain-funcs

DESCRIPTION="Erasure Code API library written in C with pluggable Erasure Code backends."
HOMEPAGE="https://bitbucket.org/tsg-/liberasurecode/overview"
SRC_URI="https://bitbucket.org/tsg-/${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
CUSTOM_VERSION="f61e907d2bbc"
S="${WORKDIR}/tsg--${PN}-${CUSTOM_VERSION}"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"

RDEPEND=""
DEPEND="sys-devel/autoconf
doc? ( app-doc/doxygen )"

src_prepare() {
sed -i -e 's/-O2\ //g' \
-e 's/mmx\ /mmx2\ /g' \
-e 's/cat\ g/#cat\ g/g' configure.ac || die
sed -i -e "s/^TARGET_DIR.*$/TARGET_DIR=\/usr\/share\/doc\/${PF}\/html/g" doc/Makefile.am || die
eautoreconf -i -v || die "autoconf failed"
}

src_configure() {
econf --htmldir /usr/share/doc/${PF}
}

src_install() {
emake DESTDIR="${D}" install
rm "${D}"/usr/$(get_libdir)/*.la || die
}

0 comments on commit 1edf0ff

Please sign in to comment.