Skip to content

Commit

Permalink
dev-ruby/facter: 3.12.3 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Jan 15, 2019
1 parent 8d74130 commit 1f1d11f
Show file tree
Hide file tree
Showing 2 changed files with 111 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/facter/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST facter-3.12.1.tar.gz 390863 BLAKE2B 3326fc52e95e73c3f083fead5b9e5c6e4fa691d99c5948dc2ffb1a1aeebc928e6a08dd4d09b417cbb33cecb776d75c488956df7b2fb9c5f937a20788ad3466f4 SHA512 34ed1cb50a38a8137301682c46c91c6b409be78c6349677b6544e082fb388248c4878719f57327b6ee4d0d2f35ff171a62afe5e3cc5972e0e9b24e3239a23216
DIST facter-3.12.2.tar.gz 391789 BLAKE2B a4476dd37629aa770d66c2597d29a2bf46ae67df2484bffc8c66fb18a0a93eea58bb11fbfb117c8f4778e10649315b1b53b4a609bc51327e29e87dcb00e96d07 SHA512 82901e973c187faf2b70863fe34e46d4f8f4a706364587fa293a8b91818c75bd3ec3cc6e5784bcb600f3dacb2c43c918708ae0996ea0e0e68cbcfaec458f9c27
DIST facter-3.12.3.tar.gz 391836 BLAKE2B 60ec23ab9df0d6ca069608c897949be8aaf719b2ab1b71455871a9364b7d0111ec78753cdb45d082041d2b028bac8e468a415a2bd9a15fe51dc69ec9738dc723 SHA512 d1568ca606b07c67f2e293b020dc5c2d399d5080857e47d3c748a7d104f75231d59dc95d54e5504b24f951ce540d1223102ee1b882e4495633ed89324ccc1c7b
DIST facter-3.9.2.tar.gz 380883 BLAKE2B d2804664e0499715230e5696c5a9ebae933f5b43dfb37154251d47763c2c7f78cfa8d1413dd836e5a0c76ed67300d066fa5bb390f17f85cd4cb7a444eaf0d133 SHA512 bc040826311bbff40f5a151ade315d9d47ef1e0f3faa570805e48ca55405265e66308230118b9cd59f701ecd76a7b0fd4d9200dd4ace838521223a162b105374
110 changes: 110 additions & 0 deletions dev-ruby/facter/facter-3.12.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,110 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby23 ruby24 ruby25"

# git-r3 goes after ruby-ng so that it overrides src_unpack properly
inherit cmake-utils eutils multilib ruby-ng

DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="debug test"
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
EGIT_BRANCH="master"
else
[[ "${PV}" = *_rc* ]] || \
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi

BDEPEND="
>=sys-devel/gcc-4.8:*
dev-cpp/cpp-hocon"
COMMON_DEPEND="
>=dev-libs/leatherman-1.0.0:=
dev-libs/openssl:*
sys-apps/util-linux
app-emulation/virt-what
net-misc/curl
>=dev-libs/boost-1.54:=[nls]
>=dev-cpp/yaml-cpp-0.5.1
!<app-admin/puppet-4.0.0"

ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"

RDEPEND="${COMMON_DEPEND}"
DEPEND="${BDEPEND}
${COMMON_DEPEND}"

# restore ${S} and override all phases exported by ruby-ng.eclass
S="${WORKDIR}/${P}"

pkg_setup() {
ruby-ng_pkg_setup
}

src_unpack() {
default

if [[ ${PV} == 9999 ]] ; then
git-r3_src_unpack
fi
}

src_prepare() {
# be explicit about the version of rspec we test with
sed -i -e '/libfacter.*specs/ s/rspec/rspec-2/' \
CMakeLists.txt || die
# be more lenient for software versions for tests
sed -i -e '/rake/ s/~> 10.1.0/>= 10/' \
-e '/rspec/ s/2.11.0/2.11/' \
-e '/mocha/ s/0.10.5/0.14.0/' lib/Gemfile || die
# patches
default
cmake-utils_src_prepare
}

each_ruby_configure() {
# hack for correct calculation of relative path from facter.rb to
# libfacter.so
my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
}

src_configure() {
ruby-ng_src_configure

local mycmakeargs=(
-DCMAKE_VERBOSE_MAKEFILE=ON
-DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
-DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
)
if use debug; then
mycmakeargs+=(
-DCMAKE_BUILD_TYPE=Debug
)
fi
cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_test() {
cmake-utils_src_test
}

each_ruby_install() {
doruby "${BUILD_DIR}"/lib/facter.rb
}

src_install() {
cmake-utils_src_install
ruby-ng_src_install
}

0 comments on commit 1f1d11f

Please sign in to comment.