Skip to content

Commit

Permalink
net-mail/mu: Bump to version 0.9.16
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
vikraman committed Jan 24, 2016
1 parent 7595feb commit 1f6e142
Show file tree
Hide file tree
Showing 2 changed files with 87 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-mail/mu/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST mu-0.9.15.tar.gz 2203193 SHA256 60c63fdf1b726696cb0028b86eaee2aa72e171493b2d5626ea173b912ff25d4c SHA512 36a0dcaa9b355c7a75f1d8c7730241ade979ec050e18f8609b840d6dff6befc96cf3fb649b8970649542724b2c20482099aaf9827b17a5e9618eb13cdda9c4b5 WHIRLPOOL e627d2553cc466725c3d1c339fb03fe08f784b069b01cc1da26c7761cc0cd03d28da5f8bf06e36e5d6dd23cee6ecbef232c45d4447b9b32b543efbb0a4cbb8eb
DIST mu-0.9.16.tar.gz 2212969 SHA256 af086880b00a6954bc1135b226b66a33205893600c8dd04139a6871c62c6f05c SHA512 8cf9b83aea287ee79b5160ed19e7dc6ef27f0784143b5eac9cf55d07b7718bc777624d752e0b407258b5078e998544d18dbb258a7eb03cafe55596f07a60d1f4 WHIRLPOOL 96a7a2fce4083d2bc3b583d59d04b26231fae67792e0d3846ff480020d481cfdeac0fb58b9e9122b5e1963380d493ef08a30fd3a03a8a7e9960c78a0932bf64c
DIST mu-0.9.9.5.tar.gz 1230322 SHA256 17e29a68c020a84441a38033067f6f538217b5d691b9c475f9593ab47ca493c3 SHA512 bd9814c670391f28a5be4b7c064f2bfc6a9428d94c88476539323688fc86df72f600cec30a87fb2b242dbeb717eb3a39c95ac09091c4c05c1886824e3052972b WHIRLPOOL bad0439b44524254a5113522cf2eafeb68604300dbc6822a9170c0ef4c336f1874428df0bfa25c7b2e7657b49d2a74cf06ce7ebb88e4e21458b87971fc178045
DIST mu-0.9.9.6.tar.gz 2172349 SHA256 4ae4ca7f433dcfc6dfd85a41873914c1bda5c43de02ad2a030cd449f84d629cb SHA512 0213033aa7599a5120c38a4b9ec018357ebd63a3c4828e0f9d7af41529dc1b001db8d506408b0341e0efe9835fbd21dbf23c836920c98ae2caabcb0cdc7dac2b WHIRLPOOL 577e5eef5874d6cdc667e967a6722308d4e99035b8265f24030ced851d976a215bdd9ce209510a75d362af76d15116a475af6e5abb5d5be04b95f549d5ecb901
DIST mu-0.9.9.tar.gz 1185624 SHA256 83f8e2814ba1a89a3153ab3dcd21105cc62e1386c176c5312ccb6bae0af02013 SHA512 1dc8608a77381d6ad0f26e3729f17a0c5bc2a90cbefa217159c8dc432c2bb9f7d495d08053852bf10451a3b5ac40e325ad44cb7d9f032f8337cd094b121da143 WHIRLPOOL de9406c0995bfe6592cb411eeb03b6681f79e15df0633857beb502bf2825b7974c79039298f5cf682be9e45d6237b463a5dcd3b5930ebb99456cbf0b1497890a
Expand Down
86 changes: 86 additions & 0 deletions net-mail/mu/mu-0.9.16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit autotools-utils base elisp-common

DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
SRC_URI="https://github.com/djcb/mu/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="emacs gui"

# net-mail/mailutils also installes /usr/bin/mu. Block it until somebody
# really wants both installed at the same time.
DEPEND="
dev-libs/gmime:2.6
dev-libs/xapian
dev-libs/glib:2
gui? (
x11-libs/gtk+:3
net-libs/webkit-gtk:3 )
emacs? ( >=virtual/emacs-23 )
!net-mail/mailutils"
RDEPEND="${DEPEND}"

SITEFILE="70mu-gentoo.el"

src_prepare(){
eautoreconf
}

src_configure() {
# Todo: Make a guile USE-flag as soon as >=guile-2 is avaiable
# Note: --disable-silent-rules is included in EAPI-5
econf --disable-guile \
$(use_enable gui webkit) \
$(use_enable gui gtk) \
$(use_enable emacs mu4e)
}

src_install () {
dobin mu/mu
if use gui; then
dobin toys/mug/mug
fi
dodoc AUTHORS HACKING NEWS NEWS.org TODO README README.org ChangeLog
if use emacs; then
elisp-install ${PN} mu4e/*.el mu4e/*.elc
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
# TODO: Add guile man page when guile-2 is available.
doman man/mu-add.1 man/mu-bookmarks.5 man/mu-cfind.1 man/mu-easy.1 \
man/mu-extract.1 man/mu-find.1 man/mu-help.1 man/mu-index.1 \
man/mu-mkdir.1 man/mu-remove.1 man/mu-server.1 man/mu-verify.1 \
man/mu-view.1 man/mu.1
if use gui; then
dobin man/mug.1
fi
}

src_test () {
# Note: Fails with parallel make
emake -j1 check
}

pkg_postinst() {
if use emacs; then
einfo "To use mu4e you need to configure it in your .emacs file"
einfo "See the manual for more information:"
einfo "http://www.djcbsoftware.nl/code/mu/mu4e/"
fi

elog "If you upgrade from an older major version,"
elog "then you need to rebuild your mail index."

use emacs && elisp-site-regen
}

pkg_postrm() {
use emacs && elisp-site-regen
}

0 comments on commit 1f6e142

Please sign in to comment.