Skip to content

Commit

Permalink
dev-tex/dot2tex: add Python 3.10, tests
Browse files Browse the repository at this point in the history
  • Loading branch information
thesamesam committed May 22, 2022
1 parent a5d5430 commit 1f7ec26
Showing 1 changed file with 19 additions and 5 deletions.
24 changes: 19 additions & 5 deletions dev-tex/dot2tex/dot2tex-2.11.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8..9} )
EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1

DESCRIPTION="A Graphviz to LaTeX converter"
Expand All @@ -20,8 +19,23 @@ DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
RDEPEND="
dev-python/pydot[${PYTHON_USEDEP}]
media-gfx/graphviz"
DEPEND="${DEPEND}
doc? ( dev-python/sphinx )"
DEPEND="${DEPEND}"
BDEPEND="doc? ( dev-python/sphinx )"

EPYTEST_DESELECT=(
# https://github.com/kjellmf/dot2tex/issues/94
tests/test_dot2tex.py::MultipleStatements::test_semicolon
)

distutils_enable_tests pytest

python_prepare_all() {
# Syntax failures (old-style print)
# Looks fixed in master: https://github.com/kjellmf/dot2tex/commit/38aeef9615f90fe347c5c45d514eaf00b116422b
rm -r "${S}"/tests/experimental || die

distutils-r1_python_prepare_all
}

python_compile_all() {
if use doc ; then
Expand Down

0 comments on commit 1f7ec26

Please sign in to comment.