Skip to content

Commit

Permalink
gnome-extra/cinnamon-settings-daemon: New upstream version 3.8.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
krifisk committed Jul 31, 2018
1 parent f0b6e96 commit 1fa48e6
Show file tree
Hide file tree
Showing 3 changed files with 145 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/cinnamon-settings-daemon/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cinnamon-settings-daemon-3.6.1.tar.gz 995005 BLAKE2B c512fe53b707099dca0926893f03056d508bbe22026367c3212a99f22df60d629e02e080fccdeb73151c7aa7e93396b47bede1820059f4a53eace11a56ae5521 SHA512 48a28decff08a191f4ec604386c3bb5c07001d4bc4f7b6d1da379626b41650653fdd14205bbed5321c41fbc281e8638b17e1de30dbba5d299f79cde03216cb33
DIST cinnamon-settings-daemon-3.8.4.tar.gz 660607 BLAKE2B 1db6e8677c9f9e1fc649d29b3de46d2797f01dbaad3a907329eb6781c6c4ec17706d06045ae230315c7802a5ea176dda73dfcd437fd07e3398ad732e96240a83 SHA512 5bd91e781d47413b50b69b6a8d4cbe9060579452db7408d375f01b05b4070caa684d333ef875a7dda85d1acad3442cddd38e13167fa198e3a5540fef7bedfb75
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GNOME2_LA_PUNT="yes"

inherit autotools eutils gnome2 virtualx

DESCRIPTION="Cinnamon's settings daemon"
HOMEPAGE="http://cinnamon.linuxmint.com/"
SRC_URI="https://github.com/linuxmint/cinnamon-settings-daemon/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+colord cups input_devices_wacom smartcard systemd"
RESTRICT=test

# udev is non-optional since lots of plugins, not just gudev, pull it in
RDEPEND="
>=dev-libs/glib-2.38:2
>=gnome-base/libgnomekbd-3.6
>=gnome-base/librsvg-2.36.2
>=gnome-extra/cinnamon-desktop-2.8.0:0=
media-libs/fontconfig
>=media-libs/lcms-2.2:2
media-libs/libcanberra:0=[gtk3]
sys-apps/dbus
>=sys-auth/polkit-0.97
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.9.10:3
>=x11-libs/libnotify-0.7.3:0=
x11-libs/libX11
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libxklavier
virtual/libgudev:=
>=sys-power/upower-0.9.11
colord? ( >=x11-misc/colord-0.1.27:= )
cups? ( >=net-print/cups-1.4[dbus] )
input_devices_wacom? (
>=dev-libs/libwacom-0.7
x11-drivers/xf86-input-wacom
x11-libs/libXtst )
smartcard? ( >=dev-libs/nss-3.11.2 )
systemd? ( sys-apps/systemd:0= )
!systemd? ( sys-auth/elogind:0= )
"
DEPEND="${RDEPEND}
dev-libs/libxml2:2
>=dev-util/intltool-0.37.1
x11-base/xorg-proto
virtual/pkgconfig
"

src_prepare() {
# make colord and wacom optional
eapply "${FILESDIR}"/${PN}-3.0.1-optional.patch
eapply "${FILESDIR}"/${PN}-3.8.0-accountservice.patch

# Disable broken test
sed -e '/g_test_add_func ("\/color\/edid/d' \
-i plugins/color/gcm-self-test.c || die

eautoreconf
gnome2_src_prepare
}

src_configure() {
# no point in disabling gudev since other plugins pull it in
gnome2_src_configure \
--disable-static \
--enable-gudev \
--enable-polkit \
--enable-logind \
--disable-accountservice \
$(use_enable colord color) \
$(use_enable cups) \
$(use_enable smartcard smartcard-support) \
$(use_enable input_devices_wacom wacom)
}

src_test() {
virtx emake check
}
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
From 15b1c1488f28e69cee86ff25bf0c95ebf5245add Mon Sep 17 00:00:00 2001
From: Kristian Fiskerstrand <[email protected]>
Date: Sat, 30 Jun 2018 22:35:52 +0200
Subject: [PATCH] Make account service optional

---
configure.ac | 6 ++++++
plugins/background/csd-background-manager.c | 4 ++--
2 files changed, 8 insertions(+), 2 deletions(-)

diff --git a/configure.ac b/configure.ac
index af5d3a4..a30126e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,6 +166,12 @@ else
fi
AM_CONDITIONAL(HAVE_GUDEV, test x$have_gudev = xyes)

+AC_ARG_ENABLE(accountservice, AS_HELP_STRING([--disable-accountservice],[Disable accountservice]), enable_accountservice=$enableval)
+
+if test x$enable_accountservice = "xyes"; then
+ AC_DEFINE(HAVE_ACCOUNTSERVICE, 1, [define if accountservice is available])
+fi
+
dnl ---------------------------------------------------------------------------
dnl - common
dnl ---------------------------------------------------------------------------
diff --git a/plugins/background/csd-background-manager.c b/plugins/background/csd-background-manager.c
index 282094a..a692c6e 100644
--- a/plugins/background/csd-background-manager.c
+++ b/plugins/background/csd-background-manager.c
@@ -135,9 +135,9 @@ settings_change_event_cb (GSettings *settings,
{
gnome_bg_load_from_preferences (manager->priv->bg,
manager->priv->settings);
-
+#ifdef HAVE_ACCOUNTSERVICE
gnome_bg_set_accountsservice_background (gnome_bg_get_filename (manager->priv->bg));
-
+#endif
return FALSE;
}

diff --git a/plugins/background/csd-background-manager.c
b/plugins/background/csd-background-manager.c
index a692c6e..a99b478 100644
--- a/plugins/background/csd-background-manager.c
+++ b/plugins/background/csd-background-manager.c
@@ -186,8 +186,9 @@ setup_bg (CsdBackgroundManager *manager)
watch_bg_preferences (manager);
gnome_bg_load_from_preferences (manager->priv->bg,
manager->priv->settings);
-
+#ifdef HAVE_ACCOUNTSERVICE
gnome_bg_set_accountsservice_background (gnome_bg_get_filename (manager->priv->bg));
+#endif
}

0 comments on commit 1fa48e6

Please sign in to comment.