forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-cluster/kube-controller-manager: 1.21.6 bump
Signed-off-by: William Hubbs <[email protected]>
- Loading branch information
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,5 @@ | ||
DIST kubernetes-1.20.11.tar.gz 34514143 BLAKE2B 498107e2ef225964b28868ee1aa37721f7d667160b81f50b486ccfd961047a842dd00d7f75b03781e0891d5e735d93b19364ab31a111079317fffc0ff0b879be SHA512 eddf4690ec034c6b09c13e939d172e96072e131416b137022ed664ad5604446c8ca95038ff2f622b41a6d000900b836b0d708f75ac6c9574a7d1b262f73bba1a | ||
DIST kubernetes-1.20.12.tar.gz 34540977 BLAKE2B 7e61a3ffc6053ed9e6985541cca65af8e4adfd032984d9f3aad36dc61a0deb5706dcbb05d0dda68f2d9d806ccf53580051702e1aa1b3ac5d612cd6dfea553ee8 SHA512 42f9d000454ae4717a9a7026fa0f1af192e160deddc6e44044993183036e67bdb9fdae02d9fcb7556370f75a44a739c49da5daf091d3b88b6dd4101e6aafe6ac | ||
DIST kubernetes-1.21.5.tar.gz 36128382 BLAKE2B 561de62a9be5c7bf49362732a098cc3bcadff9d006853de1beb73c2ae8def4249b9b3df4bd96a89aa4646929874ab2f0132212f38c98e411424f5887c02d6590 SHA512 bef73a90b31ea9c72070efc52c4e2c6aed1fde5bb0c2b391394148a394cf020071793b368a429e3d11f3e1afa24a3da9ec82b5ba64d61e2fd00209c796d5b7b3 | ||
DIST kubernetes-1.21.6.tar.gz 36137598 BLAKE2B f8c85793be4b155d55a88017b429890921b4344b3ba440132f8d1b6aa43ad98bd04e539b834c3f57ce660636aefce172a09b15abd0860cdb090f6748152f50bb SHA512 a53dc25aa091075d73b7f8ae9a518c019a16b821bce6cfe3ff191cf4098df8851de03ec0a9292e534045323b8300532a23e6caceae3e6dfaea00471eac16a223 | ||
DIST kubernetes-1.22.2.tar.gz 35997127 BLAKE2B bcc5deb9f446032baeff60b3f75e11c75af0e69fd0e50df789d2b7b532f9e839875ef4227729166d667f022816b321bacf219b0fdeaa2d0da552587d4a9a4067 SHA512 81045b0432f60a865c79f408921ff7c5865cdcb297c4cf17f741a08a5fa0f2af9e8c938e54e73c532dbeb643316e8acf983a0e9203be8ce920c2ae588dec6554 |
39 changes: 39 additions & 0 deletions
39
sys-cluster/kube-controller-manager/kube-controller-manager-1.21.6.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit go-module | ||
|
||
DESCRIPTION="Kubernetes Controller Manager" | ||
HOMEPAGE="https://kubernetes.io" | ||
SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64" | ||
IUSE="hardened" | ||
|
||
COMMON_DEPEND="acct-group/kube-controller-manager | ||
acct-user/kube-controller-manager" | ||
DEPEND="${COMMON_DEPEND}" | ||
RDEPEND="${COMMON_DEPEND} | ||
!sys-cluster/kubernetes" | ||
BDEPEND=">=dev-lang/go-1.16" | ||
|
||
RESTRICT+=" test" | ||
S="${WORKDIR}/kubernetes-${PV}" | ||
|
||
src_compile() { | ||
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \ | ||
emake -j1 GOFLAGS=-v GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN} | ||
} | ||
|
||
src_install() { | ||
dobin _output/bin/${PN} | ||
newinitd "${FILESDIR}"/${PN}.initd ${PN} | ||
newconfd "${FILESDIR}"/${PN}.confd ${PN} | ||
insinto /etc/logrotate.d | ||
newins "${FILESDIR}"/${PN}.logrotated ${PN} | ||
keepdir /var/log/${PN} | ||
fowners ${PN}:${PN} /var/log/${PN} | ||
} |