Skip to content

Commit

Permalink
media-libs/imlib2: version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.13, Repoman-3.0.2
Signed-off-by: Andrew Savchenko <[email protected]>
  • Loading branch information
bircoph committed Jan 16, 2021
1 parent 2eae9d6 commit 1fd2999
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/imlib2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST imlib2-1.6.1.tar.gz 1038614 BLAKE2B 89751ea5548e86b810d621cbcd5b3d37c7ddbedc9e634095f61d91779c1e96d50f87842136687e2b9cefa249b17fc98df61d07b368c7c4f466687ed38f2ed70f SHA512 0c6d874973c46c7e96e49fc391d463ec8c7c5ce9de682600cb4e28ca81ff0366a02055cbec2a2b743204051243d20b2316ab602b98df9d03dcf319297f7e6a13
DIST imlib2-1.7.1.tar.bz2 893631 BLAKE2B 637bf70ea223a63c51def0fac4102683a090de41a1f5904d6232fd2fa004915e3dcde54eac51d16532d2df83a0f8df127266766ac3700ae2948d39fefef512b8 SHA512 36e457855da0f129c7e7ba3dfcb44162b6624b1d56df5f84448495a96fe9ad1ce3e6c628222630be7274476722c4feaa8e1648d1e463439ca758e66ce9645970
78 changes: 78 additions & 0 deletions media-libs/imlib2/imlib2-1.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit multilib-minimal toolchain-funcs

DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
HOMEPAGE="https://www.enlightenment.org/
https://sourceforge.net/projects/enlightenment/files/imlib2-src/"
SRC_URI="https://downloads.sourceforge.net/enlightenment/${P}.tar.bz2"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="+X bzip2 cpu_flags_x86_mmx cpu_flags_x86_sse2 doc +gif +jpeg mp3 +png +shm
static-libs +tiff +webp zlib"

REQUIRED_USE="shm? ( X )"

RDEPEND="
media-libs/freetype:2[${MULTILIB_USEDEP}]
bzip2? ( app-arch/bzip2[${MULTILIB_USEDEP}] )
gif? ( media-libs/giflib[${MULTILIB_USEDEP}] )
jpeg? ( virtual/jpeg:0=[${MULTILIB_USEDEP}] )
mp3? ( media-libs/libid3tag[${MULTILIB_USEDEP}] )
png? ( >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}] )
tiff? ( >=media-libs/tiff-4.0.4:0[${MULTILIB_USEDEP}] )
webp? ( media-libs/libwebp:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
)
zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
!<media-plugins/imlib2_loaders-1.7.0
"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )"
BDEPEND="virtual/pkgconfig"

multilib_src_configure() {
local myeconfargs=(
$(use_with X x)
$(use_with bzip2)
$(use_with gif)
$(use_with jpeg)
$(use_with mp3 id3)
$(use_with png)
$(use_with shm x-shm-fd)
$(use_enable static-libs static)
$(use_with tiff)
$(use_with webp)
$(use_with zlib)
)

# imlib2 has different configure options for x86/amd64 assembly
if [[ $(tc-arch) == amd64 ]]; then
myeconfargs+=( $(use_enable cpu_flags_x86_sse2 amd64) --disable-mmx )
else
myeconfargs+=( --disable-amd64 $(use_enable cpu_flags_x86_mmx mmx) )
fi

ECONF_SOURCE="${S}" \
econf "${myeconfargs[@]}"
}

multilib_src_install() {
V=1 emake install DESTDIR="${D}"
find "${D}" -name '*.la' -delete || die
}

multilib_src_install_all() {
if use doc; then
local HTML_DOCS=( "${S}"/doc/. )
rm "${S}"/doc/Makefile.{am,in} || die
fi
einstalldocs
}

0 comments on commit 1fd2999

Please sign in to comment.