Skip to content

Commit

Permalink
dev-python/lmfit: Bump to 1.0.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Feb 8, 2021
1 parent 4c0cafd commit 1fd59af
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/lmfit/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST lmfit-1.0.1.tar.gz 258368 BLAKE2B bd2956cb9519f9303d0d2707b0333839ce471f62f53c907870bb6b8ab867cbcd1581d82a1959a6c3c734bd6b8074a769f0587706b3172800cbdef979db3a148d SHA512 1ae3e2cb25625a9b24c261d81c8f1ba0389266724581762f6e0a96140c84e43acd527ab1b83b862bf7b3b4c0b1b9755ee38d0c52e63fe89ea41f2d010b1e5c0d
DIST lmfit-1.0.2.tar.gz 306039 BLAKE2B ab5fcda566f81f00a9d2371f6ae5b3477ed015c70e9b9faf8c5228e3f75f0bf9085d9bd3789042af7b46813d0b6c88f96da37ce295593a5368144d53f5f1799b SHA512 85adeac989117dab3cc9aaf216c37ea5087452351a7978238929216dd9d9be8b6b6790103d4fbbf5211a943c43fb99461750cf58287e2b18c27f66eeacc6ed9a
35 changes: 35 additions & 0 deletions dev-python/lmfit/lmfit-1.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1

DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
HOMEPAGE="https://lmfit.github.io/lmfit-py/ https://github.com/lmfit/lmfit-py/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

RDEPEND="
>=dev-python/asteval-0.9.16[${PYTHON_USEDEP}]
>=dev-python/numpy-1.16[${PYTHON_USEDEP}]
>=dev-python/uncertainties-3.0.1[${PYTHON_USEDEP}]
>=dev-python/scipy-1.2[${PYTHON_USEDEP}]
"

distutils_enable_tests pytest

python_test() {
local deselect=(
# numpy warning mismatch
tests/test_confidence.py::test_confidence_warnings
tests/test_model.py::TestUserDefiniedModel::test_extra_param_issues_warning
)

pytest -vv ${deselect[@]/#/--deselect } ||
die "Tests failed with ${EPYTHON}"
}

0 comments on commit 1fd59af

Please sign in to comment.