forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge remote-tracking branch 'github/pr/645'.
- Loading branch information
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,5 @@ | ||
DIST ripe.atlas.cousteau-1.0.6.tar.gz 45467 SHA256 1407b003a03f359739d35010812af2841bc9df2784cd2078e55ac34d0a858ad6 SHA512 212c9890af269f945d01a1b587ba87583cbde87ce0a64b09e053644f9fa4cd01414a1092a39d0d21d68b3bd5977e0159c6a32196aaadbd78940fd4675b791daf WHIRLPOOL b65e12a89a3cfee2ca5da4311392a1ecca4fc11c4b38ca911a526cc925491b799d1504581a955dd5bd5c1feb3e71d5a73c06e5b07c26a8fbfdb28bcc748f6a1d | ||
DIST ripe.atlas.cousteau-1.0.7.tar.gz 45757 SHA256 4f99abf9e985109174bc5dae38e958dfc85dc41a872bbf916763a1f53a9e4b6b SHA512 921526beef43b666f6c64480e14f3d9d73e980ea6696964791c8f663c218f2c1c5658f2d9dc9ef4e9d40687b244d98b7775b3eeda74bd4886842f18e073765de WHIRLPOOL 1916a0af20a60b1435bb3e02d7791237c4913453d5180e8f004572e4d5c7dcecfe46afd11b11c46a64162aa146aa492f9df2d002d51567a89b9248fb5038a960 | ||
EBUILD ripe-atlas-cousteau-1.0.6.ebuild 937 SHA256 b8b08a040230a6c3bc45a388c71c0dde74f47894bccfc656066dc0e80c264ca7 SHA512 fefda75c507fe675e44784ed6a0c2045b057288bd68a4ff36a449c7a207bc9c04d8add2112748ff55d4e77c5f8d54c417017fc74958b7c95f5d3d371e670df62 WHIRLPOOL 27ba1bb1b85f7f3b146f5d02924e7158c371500c4766f348232faab031a7a776682227ea4757e9877ef49aa517e15ee1d57e8d9d243c653ec868543f91312b38 | ||
EBUILD ripe-atlas-cousteau-1.0.7.ebuild 937 SHA256 b8b08a040230a6c3bc45a388c71c0dde74f47894bccfc656066dc0e80c264ca7 SHA512 fefda75c507fe675e44784ed6a0c2045b057288bd68a4ff36a449c7a207bc9c04d8add2112748ff55d4e77c5f8d54c417017fc74958b7c95f5d3d371e670df62 WHIRLPOOL 27ba1bb1b85f7f3b146f5d02924e7158c371500c4766f348232faab031a7a776682227ea4757e9877ef49aa517e15ee1d57e8d9d243c653ec868543f91312b38 | ||
MISC metadata.xml 427 SHA256 cc91371d1308841e7c75f07af6c617335fe3fc3f1e3e41a5d1b3b49dfad569da SHA512 7b2746423401fd6c54b7c7227c831d97b0763f3e26d590516f872a88b6daec6d4aee4fd9889cf8340df74d23b8f0e6b579ea2829e93a8f1f5641dbe0ed7885fa WHIRLPOOL dc929abb692354fb6bcaed4b4ac7c63d03d5c1882c144700ede4cd7d51404f3115761d2d6825027fc882472959ee1eadd41135c9356813ac52ad68c53170a725 |
37 changes: 37 additions & 0 deletions
37
www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.7.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,37 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( python2_7 python3_4 ) | ||
|
||
inherit distutils-r1 | ||
|
||
MY_PN=${PN//-/.} | ||
DESCRIPTION="A Python wrapper around the RIPE Atlas API" | ||
HOMEPAGE="https://atlas.ripe.net/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.cousteau/ripe.atlas.cousteau-${PVR}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
S="${WORKDIR}/${MY_PN}-${PVR}" | ||
|
||
RDEPEND=" | ||
>=dev-python/socketio-client-0.6.5[${PYTHON_USEDEP}] | ||
>=dev-python/requests-2.7.0[${PYTHON_USEDEP}] | ||
dev-python/python-dateutil[${PYTHON_USEDEP}]" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
"${RDEPEND}" | ||
dev-python/nose[${PYTHON_USEDEP}] | ||
dev-python/jsonschema[${PYTHON_USEDEP}] | ||
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )" | ||
|
||
python_test() { | ||
nosetests --verbose || die "Tests failed with ${EPYTHON}" | ||
} |