forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
www-apps/gitea: Version bump to 1.1.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
70 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gitea-1.0.2.tar.gz 13448604 SHA256 f75e220f8c44a9b7c67d2d5339479e690df9f03ec3337eede3aab0c7e8e55c87 SHA512 1826e60961adc585fd54a2c913e6cfaa9754052a932981f83eb6a1f2521d09eb7165545f80494439763c8f13bb1f4ffc24b791162cae7b739fd9eb96f7db530c WHIRLPOOL 3afcfbf4d15b94b4b8e5fde511626ce6acfbf201a58b54f3cd077b6c6487f62b3a0b3e4ef7c3c4526a432e0aa4833e038ca7d69e2e09cf9fe329ea65607f42ab | ||
DIST gitea-1.1.0.tar.gz 13014916 SHA256 baf35f5b4920498c91e66d6afa13fa4320af9997f3321b1176fac0b0384a4d6f SHA512 206b3b3b2af13634573bb956f7a7db11a45dba36b73a48fb2561018b445b9f7d215d77af6ed1b985d8098d835502544347974223d3892a75abfdce7f5769cbba WHIRLPOOL 6ffb6e452f64bbc64802c7e17e2e178a651ae07739997614c6574a75b9cefdfcb99a060e7b57cd304847526a7160b8ce1ade72346348ea967bb3302d71879eae |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,69 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit user golang-build golang-vcs-snapshot | ||
|
||
EGO_PN="code.gitea.io/gitea/..." | ||
GIT_COMMIT="1d65291" | ||
ARCHIVE_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm" | ||
|
||
DESCRIPTION="A painless self-hosted Git service, written in Go" | ||
HOMEPAGE="https://github.com/go-gitea/gitea" | ||
SRC_URI="${ARCHIVE_URI}" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
DEPEND="dev-go/go-bindata" | ||
RDEPEND="dev-vcs/git" | ||
|
||
pkg_setup() { | ||
enewgroup git | ||
enewuser git -1 /bin/bash /var/lib/gitea git | ||
} | ||
|
||
src_prepare() { | ||
default | ||
local GITEA_PREFIX=${EPREFIX}/var/lib/gitea | ||
sed -i -e "s/git rev-parse --short HEAD/echo ${GIT_COMMIT}/"\ | ||
-e "s/^LDFLAGS += -X \"main.Version.*$/LDFLAGS += -X \"main.Version=${PV}\"/"\ | ||
-e "s/-ldflags '-s/-ldflags '/" src/${EGO_PN%/*}/Makefile || die | ||
sed -i -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${GITEA_PREFIX}/data#"\ | ||
-e "s#^PATH = data/gitea.db#PATH = ${GITEA_PREFIX}/data/gitea.db#"\ | ||
-e "s#^PROVIDER_CONFIG = data/sessions#PROVIDER_CONFIG = ${GITEA_PREFIX}/data/sessions#"\ | ||
-e "s#^AVATAR_UPLOAD_PATH = data/avatars#AVATAR_UPLOAD_PATH = ${GITEA_PREFIX}/data/avatars#"\ | ||
-e "s#^TEMP_PATH = data/tmp/uploads#TEMP_PATH = ${GITEA_PREFIX}/data/tmp/uploads#"\ | ||
-e "s#^PATH = data/attachments#PATH = ${GITEA_PREFIX}/data/attachments#"\ | ||
-e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#" src/${EGO_PN%/*}/conf/app.ini || die | ||
} | ||
|
||
src_compile() { | ||
GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN%/*} generate | ||
TAGS="bindata pam sqlite" LDFLAGS="" CGO_LDFLAGS="-fno-PIC" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN%/*} build | ||
} | ||
|
||
src_install() { | ||
pushd src/${EGO_PN%/*} || die | ||
dobin gitea | ||
insinto /var/lib/gitea/conf | ||
newins conf/app.ini app.ini.example | ||
popd || die | ||
insinto /etc/logrotate.d | ||
newins "${FILESDIR}"/gitea.logrotated gitea | ||
newinitd "${FILESDIR}"/gitea.initd gitea | ||
newconfd "${FILESDIR}"/gitea.confd gitea | ||
keepdir /var/log/gitea /var/lib/gitea/data | ||
fowners -R git:git /var/log/gitea /var/lib/gitea/ | ||
} | ||
|
||
pkg_postinst() { | ||
if [[ ! -e ${EROOT}/var/lib/gitea/conf/app.ini ]]; then | ||
elog "No app.ini found, copying the example over" | ||
cp "${EROOT}"/var/lib/gitea/conf/app.ini{.example,} || die | ||
else | ||
elog "app.ini found, please check example file for possible changes" | ||
fi | ||
} |