Skip to content

Commit

Permalink
app-office/texstudio: Version bump (v3.0.1)
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.4, Repoman-2.3.23
Signed-off-by: Mikle Kolyada <[email protected]>
  • Loading branch information
Zlogene committed Sep 2, 2020
1 parent 6128f01 commit 2020a63
Show file tree
Hide file tree
Showing 2 changed files with 86 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/texstudio/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST texstudio-3.0.0.tar.gz 35982392 BLAKE2B 1eed56fe21aac141df41f251621a902a20153b0eaafc995b56fa8c3fbcc213685710e45202fbb90a071a0efac591c86588d4c5fe3727e603e0a58e149ed6864e SHA512 d922f576055fc345e7e0125074c6dbb473c6fb95aa06ae1ffc15f3b89fbdc7c5a44a13d4a32b770bef10c7bae7211a4bf3a269996eda1b3a0c8fd1ed8f3c4bb1
DIST texstudio-3.0.0_pre20200601.tar.gz 35982392 BLAKE2B 1eed56fe21aac141df41f251621a902a20153b0eaafc995b56fa8c3fbcc213685710e45202fbb90a071a0efac591c86588d4c5fe3727e603e0a58e149ed6864e SHA512 d922f576055fc345e7e0125074c6dbb473c6fb95aa06ae1ffc15f3b89fbdc7c5a44a13d4a32b770bef10c7bae7211a4bf3a269996eda1b3a0c8fd1ed8f3c4bb1
DIST texstudio-3.0.1.tar.gz 35982392 BLAKE2B 1eed56fe21aac141df41f251621a902a20153b0eaafc995b56fa8c3fbcc213685710e45202fbb90a071a0efac591c86588d4c5fe3727e603e0a58e149ed6864e SHA512 d922f576055fc345e7e0125074c6dbb473c6fb95aa06ae1ffc15f3b89fbdc7c5a44a13d4a32b770bef10c7bae7211a4bf3a269996eda1b3a0c8fd1ed8f3c4bb1
85 changes: 85 additions & 0 deletions app-office/texstudio/texstudio-3.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,85 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit prefix qmake-utils xdg-utils desktop

MY_PV="3.0.0alpha6"

DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="video"

COMMON_DEPEND="
app-text/hunspell:=
app-text/poppler[qt5]
>=dev-libs/quazip-0.7.2[qt5(+)]
dev-qt/designer:5
dev-qt/qtcore:5
dev-qt/qtconcurrent:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5
dev-qt/qtscript:5
dev-qt/qtsingleapplication[qt5(+),X]
dev-qt/qtsvg:5
dev-qt/qttest:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
sys-libs/zlib
x11-libs/libX11
x11-libs/libXext
video? ( media-libs/phonon[qt5(+)] )"
RDEPEND="${COMMON_DEPEND}
app-text/ghostscript-gpl
app-text/psutils
media-libs/netpbm
virtual/latex-base"
DEPEND="${COMMON_DEPEND}"

BDEPEND="virtual/pkgconfig"

S=${WORKDIR}/${PN}-${MY_PV}

src_prepare() {
default

if use video; then
sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
fi

sed \
-e '/qtsingleapplication.pri/d' \
-i ${PN}.pro || die

cp "${FILESDIR}"/texmakerx_my.pri ${PN}.pri || die
eprefixify ${PN}.pri
}

src_configure() {
eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1
}

src_install() {
local i
for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
done
emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
}

pkg_postinst() {
xdg_icon_cache_update
xdg_desktop_database_update
}

pkg_postrm() {
xdg_icon_cache_update
xdg_desktop_database_update
}

0 comments on commit 2020a63

Please sign in to comment.