Skip to content

Commit

Permalink
dev-db/mysql++: bump to v3.3.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Apr 30, 2021
1 parent 3384b3c commit 203dc27
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/mysql++/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mysql++-3.2.5.tar.gz 4748218 BLAKE2B ffceddb360cf6f0f38b7647f68e52ad9b659642c598c2aab7736813bf61d07316900d843749c2f9f4c753bd2087711ca712cc430f12b3a475c63ae3e5b11aff7 SHA512 5fa042a350322fa74afa28dc5e53f15cad32517001ab817493bf0d13a64e6559712f5e61184ef38a97bc8fe69f8732aaf436bc5d1663e4873f8baebee2e00892
DIST mysql++-3.3.0.tar.gz 4635623 BLAKE2B 0d5bb3dc7eeee92d10eb82b0537a7caff7faec2f330bb3081790b63544caa2e6967aaaf2adc8f68b9b0854da8f0374eda73d4ced50d77fbc119f83fec84376e3 SHA512 cd50f9edc9531b385d91d70aa292629dc7b839fd296f07db470f37c4748617c5c2dba647adf8965d70e2788e9264288d8ca941a6dcd8d08ff7d838e7947e6465
60 changes: 60 additions & 0 deletions dev-db/mysql++/mysql++-3.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit autotools libtool flag-o-matic

DESCRIPTION="C++ API interface to the MySQL database"
HOMEPAGE="https://tangentsoft.net/mysql++/"
SRC_URI="https://www.tangentsoft.net/mysqlpp/releases/${P}.tar.gz"

LICENSE="LGPL-2"
SLOT="0/3"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="doc"

RDEPEND="|| ( dev-db/mysql-connector-c dev-db/mariadb-connector-c )"
DEPEND="${RDEPEND}"
DOCS=( CREDITS.txt CONTRIBUTING.md doc/ssqls-pretty )
PATCHES=(
"${FILESDIR}"/${PN}-3.2.1-gold.patch
"${FILESDIR}"/${PN}-3.2.4-only-unit-tests.patch
)

src_prepare() {
# Bug filed upstream about deprecated std::auto_ptr
append-cxxflags $(test-flags-CXX -Wno-deprecated-declarations)
# Bad symlink for libtool in the archive
rm "${S}/ltmain.sh" || die

default

# we don't use eautoreconf to avoid dev-util/bakefile
_elibtoolize --auto-ltdl --install --copy --force
elibtoolize

# Current MySQL libraries are always with threads and slowly being removed
sed -i -e "s/mysqlclient_r/mysqlclient/" "${S}/configure" || die
rm "${S}/doc/"README-*-RPM.txt || die
}

src_configure() {
local myconf=(
--enable-thread-check
--with-mysql="${EPREFIX}/usr"
--with-mysql-lib="${EPREFIX}$(mysql_config --variable=pkglibdir)"
--with-mysql-include="${EPREFIX}$(mysql_config --variable=pkgincludedir)"
)
econf "${myconf[@]}"
}

src_test() {
ONLY_UNIT_TESTS=1 "${S}"/dtest || die
}

src_install() {
default
# install the docs and HTML pages
use doc && dodoc -r doc/pdf/ doc/refman/ doc/userman/ doc/html/
}

0 comments on commit 203dc27

Please sign in to comment.