Skip to content

Commit

Permalink
dev-lua/luassert: update EAPI 7 -> 8
Browse files Browse the repository at this point in the history
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Feb 9, 2022
1 parent 9c9987d commit 20492f5
Showing 1 changed file with 56 additions and 0 deletions.
56 changes: 56 additions & 0 deletions dev-lua/luassert/luassert-1.8.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

LUA_COMPAT=( lua5-{1..4} luajit )

inherit lua toolchain-funcs

DESCRIPTION="Assertion library for Lua"
HOMEPAGE="http://olivinelabs.com/busted/"
SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
IUSE="test"
REQUIRED_USE="${LUA_REQUIRED_USE}"
RESTRICT="!test? ( test )"

RDEPEND="
dev-lua/say[${LUA_USEDEP}]
${LUA_DEPS}
"

BDEPEND="
virtual/pkgconfig
test? (
dev-lua/busted[${LUA_USEDEP}]
dev-lua/lua_cliargs[${LUA_USEDEP}]
${RDEPEND}
)
"

DEPEND="${RDEPEND}"

PATCHES=( "${FILESDIR}/${PN}-1.8.0-disable-highlightcolor-test.patch" )

lua_src_test() {
busted --lua=${ELUA} || die
}

src_test() {
lua_foreach_impl lua_src_test
}

lua_src_install() {
insinto $(lua_get_lmod_dir)/luassert
doins -r src/.

einstalldocs
}

src_install() {
lua_foreach_impl lua_src_install
}

0 comments on commit 20492f5

Please sign in to comment.