Skip to content

Commit

Permalink
dev-php/PHPMailer: new version 6.0.5.
Browse files Browse the repository at this point in the history
Signed-off-by: Michael Orlitzky <[email protected]>
Package-Manager: Portage-2.3.49, Repoman-2.3.11
  • Loading branch information
orlitzky committed Oct 28, 2018
1 parent e8488b0 commit 204d8c5
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/PHPMailer/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST PHPMailer-5.2.26.tar.gz 159174 BLAKE2B 989ee85f6ca374bd7f4accf3d18fbd173bbbd3176e6846c9a2aec68f3bfca4ead4e0197f6287e2bc8ed4a125bf7fcb53240a1f8ce6a1813eaffb66067c2c4e9e SHA512 4c3e324ecd1dd23eb40f14ee785fb9b353b742ff4fb26fe0586622038157e60d64560f5ba4a625f16fad6568954d685ebbe436d88bc427d5bd260c056815b656
DIST PHPMailer-6.0.5.tar.gz 88092 BLAKE2B 0b2113b54d547d788c54cbcf18fe134a6b08f6b9eabcbad308a7d0bba8e95426fd8be77419419cbe0379be080350a1caf1690cbe3f096c178cc3a8c9506d9529 SHA512 5b18700ef26fe5de20a7ca291ece44b897182c603ed8187e0f711099325b35b20f8dbab2c456eaac1338731356661237d9b249c2f40051807b0d58ead612013c
73 changes: 73 additions & 0 deletions dev-php/PHPMailer/PHPMailer-6.0.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Full-featured email creation and transfer class for PHP"
HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"

# To help out the Composer children, the tests and examples are missing
# from the release tarballs.
IUSE="doc idn ssl"

# The ctype and filter extensions get used unconditionally, with no
# fallback and no "extension missing" exception. All of the other
# extensions are technically optional, depending on how you use
# PHPMailer and whether or not you're willing to settle for fallback
# implementations.
#
# The insane dependency string is to prevent the ctype and filter
# extensions from being provided by one version (i.e. slot) of PHP,
# while intl and unicode are provided by another.
RDEPEND="
ssl? (
idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
!idn? ( dev-lang/php:*[ctype,filter,ssl] )
)
!ssl? (
idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
!idn? ( dev-lang/php:*[ctype,filter] )
)"
BDEPEND="doc? ( dev-php/phpDocumentor )"

src_prepare() {
# OAuth.php relies on a (now non-nonexistent) autoloader. We remove
# it early so that we don't generate documentation for it later on.
rm src/OAuth.php || die 'failed to remove src/OAuth.php'
eapply_user
}

src_compile(){
if use doc; then
phpdoc --filename="src/*.php" \
--target="./html" \
--cache-folder="${T}" \
--title="${PN}" \
--sourcecode \
--force \
--progressbar \
|| die "failed to generate API documentation"
fi
}

src_install(){
# The PHPMailer class loads its language files
# using a relative path, so we need to keep the "src" here.
insinto "/usr/share/php/${PN}"
doins -r language src

dodoc README.md SECURITY.md
use doc && dodoc -r html/*
}

pkg_postinst(){
elog "${PN} has been installed in /usr/share/php/${PN}/."
elog "Upstream no longer provides an autoloader, so you will need"
elog "to include each source file (for example: PHPMailer.php,"
elog "Exception.php,...) that you need."
}

0 comments on commit 204d8c5

Please sign in to comment.