Skip to content

Commit

Permalink
app-portage/iwdevtools: add 0.11.6
Browse files Browse the repository at this point in the history
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Aug 10, 2022
1 parent e46201b commit 2100c13
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/iwdevtools/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST iwdevtools-0.11.5.tar.gz 85698 BLAKE2B 0f5b0c81735017b82144c74b2396826b2e6ea97db70704977c7885bdb00442c83023f593aeb25ab2e51f3a35cd659be98440f51e4496418a92f1559212db5b5d SHA512 05e0169a465cd4956d663f54bdc66d3c17379229b23c26a94d9deff879ef9e53b1b28f59e7cf314d36127954cb75728f008d0b0728659436ad1e63de5fb11bbb
DIST iwdevtools-0.11.6.tar.gz 85945 BLAKE2B 61c18ae0ed1c0f7e90d41af485f18f891cdd9ffbaff5437cb9f9ca88622efa0f5acd89ac8596e7d41c25a083a970143f3b226284f4566b0b8ee3718071cd6cbb SHA512 21ffda72945947658bf6867bf83d9b9ad4f6b930d4c2cee3dea551581030668ab286a4c4a07edeae937fd91f4aba08fe8e7c6506459808c4ada38502226b5b26
64 changes: 64 additions & 0 deletions app-portage/iwdevtools/iwdevtools-0.11.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson optfeature

DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
HOMEPAGE="https://github.com/ionenwks/iwdevtools"
SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
app-misc/pax-utils
app-portage/portage-utils
>=app-shells/bash-5.1
dev-libs/libxml2:2
sys-apps/diffutils
sys-apps/file
sys-apps/portage
|| ( sys-apps/util-linux app-misc/getopt )"
BDEPEND="
sys-apps/help2man
|| ( sys-apps/util-linux app-misc/getopt )
test? ( ${RDEPEND} )"

src_configure() {
local emesonargs=(
-Ddocdir=${PF}
-Deprefix="${EPREFIX}"
-Dshellcheck=false
$(meson_use test)
)

has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )

meson_src_configure
}

pkg_postinst() {
optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail

if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "Optional portage integration relies on using /etc/portage/bashrc."
elog "The example bashrc can be used as-is if not already using one:"
elog
elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
elog "Otherwise, inspect the tools' --help output and the example to integrate"
elog "(if not defining the same phase functions, the example can be sourced)."
elog
elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
elog
elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
fi
}

0 comments on commit 2100c13

Please sign in to comment.