Skip to content

Commit

Permalink
games-strategy/hedgewars: version bump to 0.9.25
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/672592
Signed-off-by: Quentin Retornaz <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Closes: gentoo#10553
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
CaseOf authored and a17r committed Jan 3, 2019
1 parent d8ba090 commit 2128068
Show file tree
Hide file tree
Showing 2 changed files with 112 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-strategy/hedgewars/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST hedgewars-src-0.9.24.1.tar.bz2 175069915 BLAKE2B 5c49b91b9a77a110a7bc8667f9621c92d638950071c8db7493b7797c2e504a214052fad6ae8554d844146eecabd794529891aebf4e54ee73f8a447ab11c6c7da SHA512 b0b166c807e0d08a763e5e88e178d6e629baa420685bbfe381db7b5ecf003175892f8c2e3b75f1f6d7663335bd5b417d1a2afdc89b9d56b348b056ee3490ed2f
DIST hedgewars-src-0.9.25.tar.bz2 175276967 BLAKE2B 8f0779ca05ffbf18f607716bbec03bf0d6633cd6c3594bcb94b78ba606ed8c36d418d7b5456574cc0a08489e143d2390ed7ebcc8637e7987231ba04c0d5b5331 SHA512 956c21a7203586485e885f98fa4eccdc2fd34b50c0f817c1f6f610af1b4f341a5bb32bb8e0ace13f78ce2fb79a489000034b89c1b56459a411c07a1809041968
DIST hedgewars_0.9.23-dfsg-2.debian.tar.xz 77488 BLAKE2B 5de6fa2ad91f1346f679d07b3b445bd119d2cdd3c715ace20fc36abe726330ccf9a9b69ec56c58cfca4cc6256ff248b0cc0b0e27caf2a79df0f1662ea7727e8e SHA512 03680446930279178ddff85a87fc27b7c26ad6d850c8f26571517ebbd6dff296db216da6b56d4bd55c659786bc5c76e2b67a63052ee38e150655e60c08f7c491
111 changes: 111 additions & 0 deletions games-strategy/hedgewars/hedgewars-0.9.25.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,111 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

CMAKE_MAKEFILE_GENERATOR=emake
inherit cmake-utils xdg-utils

MY_P=${PN}-src-${PV}
DEB_PATCH_VER=2

DESCRIPTION="A turn-based strategy, artillery, action and comedy game"
HOMEPAGE="https://www.hedgewars.org/"
SRC_URI="https://www.hedgewars.org/download/releases/${MY_P}.tar.bz2
mirror://debian/pool/main/h/${PN}/${PN}_0.9.23-dfsg-${DEB_PATCH_VER}.debian.tar.xz"
LICENSE="GPL-2 Apache-2.0 FDL-1.3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="libav server"

QA_FLAGS_IGNORED="/usr/bin/hwengine" # pascal sucks
QA_PRESTRIPPED="/usr/bin/hwengine" # pascal sucks

# qtcore:5= - depends on private header
CDEPEND="
>=dev-games/physfs-3.0.1
dev-lang/lua:0=
dev-qt/qtcore:5=
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
media-libs/libpng:0=
media-libs/libsdl2:=
media-libs/sdl2-image:=
media-libs/sdl2-mixer:=[vorbis]
media-libs/sdl2-net:=
media-libs/sdl2-ttf:=
sys-libs/zlib:=
!x86? (
libav? ( media-video/libav:= )
!libav? ( media-video/ffmpeg:= )
)"
DEPEND="${CDEPEND}
!x86? ( >=dev-lang/fpc-2.4 )
dev-qt/linguist-tools:5
server? (
>=dev-lang/ghc-6.10
dev-haskell/entropy
dev-haskell/hslogger
>=dev-haskell/mtl-2
>=dev-haskell/network-2.3
dev-haskell/random
dev-haskell/regex-tdfa
dev-haskell/sandi
dev-haskell/sha
dev-haskell/vector
dev-haskell/utf8-string
dev-haskell/yaml
>=dev-haskell/zlib-0.5.3 <dev-haskell/zlib-0.6
)
x86? (
>=dev-lang/ghc-6.10
dev-haskell/parsec
)"
RDEPEND="${CDEPEND}
app-arch/xz-utils
>=media-fonts/dejavu-2.28
media-fonts/wqy-zenhei"

S="${WORKDIR}"/${MY_P}

PATCHES=(
"${FILESDIR}"/${PN}-0.9.22-rpath-fix.patch
)

src_configure() {
local mycmakeargs=(
-DMINIMAL_FLAGS=ON
-DDATA_INSTALL_DIR="${EPREFIX}/usr/share/${PN}"
-Dtarget_binary_install_dir="${EPREFIX}/usr/bin"
-Dtarget_library_install_dir="${EPREFIX}/usr/$(get_libdir)"
-DNOSERVER=$(usex server FALSE TRUE)
-DBUILD_ENGINE_C=$(usex x86 ON OFF)
-DNOVIDEOREC=$(usex x86 TRUE FALSE)
-DCMAKE_VERBOSE_MAKEFILE=TRUE
-DPHYSFS_SYSTEM=ON
# Need to tell the build system where the fonts are located
# as it uses PhysFS' symbolic link protection mode which
# prevents us from symlinking the fonts into the right directory
# https://hg.hedgewars.org/hedgewars/rev/76ad55807c24
# https://icculus.org/physfs/docs/html/physfs_8h.html#aad451d9b3f46f627a1be8caee2eef9b7
-DFONTS_DIRS="${EPREFIX}/usr/share/fonts/wqy-zenhei;${EPREFIX}/usr/share/fonts/dejavu"
# upstream sets RPATH that leads to weird breakage
# https://bugzilla.redhat.com/show_bug.cgi?id=1200193
-DCMAKE_SKIP_RPATH=ON
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
doman man/${PN}.6
}

pkg_postinst() {
xdg_desktop_database_update
}

pkg_postrm() {
xdg_desktop_database_update
}

0 comments on commit 2128068

Please sign in to comment.