Skip to content

Commit

Permalink
dev-ros/geneus: allow pkg dupes
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/740046
Closes: https://bugs.gentoo.org/740038
Closes: https://bugs.gentoo.org/740036
Closes: https://bugs.gentoo.org/740028
Closes: https://bugs.gentoo.org/739280
Package-Manager: Portage-3.0.5, Repoman-3.0.1
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Sep 4, 2020
1 parent 0b6da07 commit 217730a
Show file tree
Hide file tree
Showing 3 changed files with 15 additions and 0 deletions.
13 changes: 13 additions & 0 deletions dev-ros/geneus/files/allow_dupes.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
Index: geneus-3.0.0/src/geneus/geneus_main.py
===================================================================
--- geneus-3.0.0.orig/src/geneus/geneus_main.py
+++ geneus-3.0.0/src/geneus/geneus_main.py
@@ -53,7 +53,7 @@ def usage(progname):
def get_pkg_map():
pkg_map = {}
for ws in workspaces.get_spaces():
- pkgs = packages.find_packages(ws)
+ pkgs = packages.find_packages_allowing_duplicates(ws)
for pkg in pkgs.values():
# packages.find_packages(workspaces.get_spaces()) returns package in high-priority-first-order, so we should not overwirte package map which is already found
# https://github.com/ros-infrastructure/catkin_pkg/blob/fa4b136b16e2d2886ab97257684f6bff243edefb/src/catkin_pkg/workspaces.py#L43
Original file line number Diff line number Diff line change
Expand Up @@ -15,3 +15,4 @@ IUSE=""

RDEPEND="dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/allow_dupes.patch" )
1 change: 1 addition & 0 deletions dev-ros/geneus/geneus-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -15,3 +15,4 @@ IUSE=""

RDEPEND="dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/allow_dupes.patch" )

0 comments on commit 217730a

Please sign in to comment.