Skip to content

Commit

Permalink
dev-util/vulkan-tools: Bump to 1.1.92.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Nick Sarnie <[email protected]>
  • Loading branch information
sarnex committed Nov 30, 2018
1 parent c707ca8 commit 21aaf38
Show file tree
Hide file tree
Showing 3 changed files with 98 additions and 1 deletion.
1 change: 1 addition & 0 deletions dev-util/vulkan-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST vulkan-tools-1.1.77.0.tar.gz 330131 BLAKE2B 3190c59745f6068fc00871f7c7c889ec2e429095d5090b0b02e1d3bbdd8613147febbbe4da3f1d48690a34577bff21bf5fd90bed77a621d0716e1b10dd9e8207 SHA512 e569e1d6da651a9f3c4669de0d4ebd301528036e283ea46049abdabca6b1b993f07e48643f91b29a38859a44770e55c8222058cf1f2a0dfd4838c37f801ba725
DIST vulkan-tools-1.1.82.0.tar.gz 342321 BLAKE2B 8591e7b16b59a1f839639642b652bcb040d9d1695a7e1cc3ccbc791703504647a517a6632db90bff9a21f7417d2219f2b7720ae1798795b31171e798b8d12ff5 SHA512 214cd30b03bf11310fe890bbcc082e515125a89591a225d113412bc41d302f8bc9a8598faaf8ca7acbd9c9ee3da43431564572e9495d966a13f90d277115d9c5
DIST vulkan-tools-1.1.92.0.tar.gz 344286 BLAKE2B 2bbf19b458b780f26b5520fa298416cda50c951fd04529da4fdf77b0e2c57d38ca1dd7e9bd08cb14cf9a7eda0b5a58623f7a75e0d421d1511ed50056c2b369ca SHA512 cdca9332b399300b7011c90ab25a8227028009ffade9c587788229175476a000843a340625691a6a7970433961b776d8aab69332a4d3b5a2d89fdc18330302cc
96 changes: 96 additions & 0 deletions dev-util/vulkan-tools/vulkan-tools-1.1.92.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,96 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )

if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Tools.git"
EGIT_SUBMODULES=()
inherit git-r3
else
EGIT_COMMIT="9bbdd552f0fd62741aa1f1e02ab3eafc45cf3c1e"
KEYWORDS="~amd64"
SRC_URI="https://github.com/KhronosGroup/Vulkan-Tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/Vulkan-Tools-${EGIT_COMMIT}"
fi

inherit python-any-r1 cmake-multilib

DESCRIPTION="Official Vulkan Tools and Utilities for Windows, Linux, Android, and MacOS"
HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="+cube +vulkaninfo X wayland"

# Old packaging will cause file collisions
RDEPEND="!<=media-libs/vulkan-loader-1.1.70.0-r999"
DEPEND="${PYTHON_DEPS}
cube? ( dev-util/glslang:=[${MULTILIB_USEDEP}] )
dev-util/vulkan-headers
media-libs/vulkan-loader:=[${MULTILIB_USEDEP},wayland?,X?]
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11:=[${MULTILIB_USEDEP}]
x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
)"

# Vulkaninfo does not support wayland
REQUIRED_USE="|| ( X wayland )
vulkaninfo? ( X )"

pkg_setup() {
MULTILIB_CHOST_TOOLS=()

if use vulkaninfo; then
MULTILIB_CHOST_TOOLS+=( /usr/bin/vulkaninfo )
fi

if use cube; then
MULTILIB_CHOST_TOOLS+=(
/usr/bin/vkcube
/usr/bin/vkcubepp
)
fi

python-any-r1_pkg_setup
}

multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=True
-DBUILD_CUBE=$(usex cube)
-DBUILD_VULKANINFO=$(usex vulkaninfo)
-DBUILD_WSI_MIR_SUPPORT=False
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
-DGLSLANG_INSTALL_DIR="/usr"
-DVULKAN_HEADERS_INSTALL_DIR="/usr"
)

# Upstream only supports one window system at a time
# If X is set at all, even if wayland is set, use X
#
# If -cube and/or -vulkaninfo is set, the flags we set
# are ignored, so we don't need to consider that
if use X; then
mycmakeargs+=(
-DCUBE_WSI_SELECTION="XCB"
-DVULKANINFO_WSI_SELECTION="XCB"
)
fi

if ! use X && use wayland; then
mycmakeargs+=(
-DCUBE_WSI_SELECTION="WAYLAND"
)
fi

cmake-utils_src_configure
}

multilib_src_install() {
cmake-utils_src_install
}
2 changes: 1 addition & 1 deletion dev-util/vulkan-tools/vulkan-tools-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ if [[ "${PV}" == "9999" ]]; then
EGIT_SUBMODULES=()
inherit git-r3
else
EGIT_COMMIT="2cfddd146d666efe0ed06ef1d2bc5565821df144"
EGIT_COMMIT="9bbdd552f0fd62741aa1f1e02ab3eafc45cf3c1e"
KEYWORDS="~amd64"
SRC_URI="https://github.com/KhronosGroup/Vulkan-Tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/Vulkan-Tools-${EGIT_COMMIT}"
Expand Down

0 comments on commit 21aaf38

Please sign in to comment.