Skip to content

Commit

Permalink
media-video/motiontrack: Allow GM usage
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/314339
Signed-off-by: Pacho Ramos <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
pacho2 committed Nov 10, 2018
1 parent d3966cf commit 21b07d7
Showing 1 changed file with 41 additions and 0 deletions.
41 changes: 41 additions & 0 deletions media-video/motiontrack/motiontrack-0.1.3-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit flag-o-matic

DESCRIPTION="A set of tools that detect motion between two images"
SRC_URI="http://gemia.de/motion/${P}.tar.gz"
HOMEPAGE="http://motiontrack.sourceforge.net"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~ppc64 ~sparc ~mips ~alpha ~hppa ~amd64"

IUSE="debug graphicsmagick imagemagick multiprocess"

RDEPEND="
imagemagick? (
!graphicsmagick? ( media-gfx/imagemagick:0= )
graphicsmagick? ( media-gfx/graphicsmagick:0=[imagemagick] )
)
!imagemagick? ( media-libs/gd )
"
DEPEND="${RDEPEND}"

src_configure() {
# fix missing inline definition
# with GCC 5, bug 570352
append-cflags -std=gnu89

econf \
$(use_enable debug) \
$(use_enable !imagemagick gd) \
$(use_enable imagemagick magick) \
$(use_enable multiprocess cluster)
}

src_install() {
default
dodoc src/TheCode.txt
}

0 comments on commit 21b07d7

Please sign in to comment.