Skip to content

Commit

Permalink
app-metrics/postgres_exporter: Version bump to 0.4.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
mrueg committed Apr 26, 2018
1 parent e3d769f commit 21c4357
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-metrics/postgres_exporter/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST postgres_exporter-0.4.5.tar.gz 3698713 BLAKE2B fd15605d59f2f78ad380b24018dc7d9d789af58be248d0b0492a720a368ca1802719467091f9e4cd9aec57318ed5948d1e725bff63fcd47a13447b64d71da7ca SHA512 82da737389ab0abcc336cb9bd32b4af8165e101c1b09543847d1cbf93a1465fe537985b9b24b5518898b81e3614d6986389a99e38c82f613525983543ec99cb4
DIST postgres_exporter-0.4.6.tar.gz 3698795 BLAKE2B 5d8a370d6f5ddbe0c8570ad14d8547a5d56dbbd9d4f2d5ef604550cd0e1e97baa5c7bbd0940704f3d8f7f25da0f26d54318b4e4732a82f68e9394c5c9b044a20 SHA512 16062a372ad8048ca0bdb41e302bde9d18dfcdc519fbf387cc7ea414667d4a8ad2984b524e7a2c86132f4b37a175c6dd9d4ce67be5cc3c9d91aa9e73cb8c4e3b
40 changes: 40 additions & 0 deletions app-metrics/postgres_exporter/postgres_exporter-0.4.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit user golang-build golang-vcs-snapshot

EGO_PN="github.com/wrouesnel/postgres_exporter"
ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="PostgreSQL stats exporter for Prometheus"
HOMEPAGE="https://github.com/wrouesnel/postgres_exporter"
SRC_URI="${ARCHIVE_URI}"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

RESTRICT="test"

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
}

src_compile() {
pushd src/${EGO_PN} || die
VERSION_SHORT="${PV}" VERSION="${PV}" GOPATH="${S}" go run mage.go binary || die
popd || die
}

src_install() {
pushd src/${EGO_PN} || die
dobin ${PN}
dodoc README.md queries.yaml
popd || die
keepdir /var/log/${PN}
fowners ${PN}:${PN} /var/log/${PN}
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
}

0 comments on commit 21c4357

Please sign in to comment.