Skip to content

Commit

Permalink
dev-php/json-schema: bump to v5.2.11
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.21, Repoman-3.0.3
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Jul 23, 2021
1 parent 546cc68 commit 21ccb0a
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/json-schema/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST json-schema-5.2.10.tar.gz 31261 BLAKE2B 2f2e3f562552105e924aa3e4408e50c6e42171cb8440ca8009166d956dcb9d4d6a3903c3b7e62bcfa228069c1e17f4faeab56e56ff935fd59fe251d27d12ab3a SHA512 b6d31b5478b93ef7dea741307648734d4d93aa4c0518b0037e81f5411810ea0570a046adb314cbee3f06da4cc9e654c419ff0be75b6ad0f5d3770c03be5707c8
DIST json-schema-5.2.11.tar.gz 31273 BLAKE2B 7b5309c772816de08a6a3b600cef1291385357879cfb1e48f548ca2cb666fc87454064d090d4ab662d7937f0bec99bc4f0f304876dd2482896aa5bf41b2ed85e SHA512 1b1981dd12fd8642c26d3be75b40111320f89b6a917dabad087ff40d3baea78304e5611cf2b931e6f8e48f5ee4d14fcbe18c68ba76a90b59702783aea5d63477
40 changes: 40 additions & 0 deletions dev-php/json-schema/json-schema-5.2.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="PHP implementation of JSON schema"
HOMEPAGE="https://github.com/justinrainbow/json-schema"
SRC_URI="https://github.com/justinrainbow/json-schema/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
# Tests are not in the release tarball
RESTRICT="test"

RDEPEND="
dev-lang/php:*
dev-php/fedora-autoloader"
DEPEND="
test? (
${RDEPEND}
dev-php/phpunit )"

src_prepare() {
default
if use test; then
cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
fi
}

src_install() {
insinto "/usr/share/php/JsonSchema"
doins -r src/JsonSchema/. "${FILESDIR}"/autoload.php
dodoc README.md
}

src_test() {
phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
}

0 comments on commit 21ccb0a

Please sign in to comment.