forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Akinori Hattori <[email protected]>
- Loading branch information
Showing
2 changed files
with
49 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST ibus-typing-booster-2.8.3.tar.gz 8184044 BLAKE2B 06b7bc3c39f8c135d5e6d2c90ceaa2df8c38041cb4cc7d583cc335bb3bbdbf4915a6bcb0fff80bbaae797e8bda74bed26077ab4739a8f9584ecfaade833eefbb SHA512 18cee36b5f5c3d6da1cb455e785317c0e2b9826e49e3b2655f4f7a3fce4bdd279ff24614083559996031876702879530799a709e196dc5d68345f0d942972dff | ||
DIST ibus-typing-booster-2.9.0.tar.gz 8191076 BLAKE2B 4b0e53679b907fce56361c60aed2d50f0ac3bef422f9c56b4b5ca8733734c0341f90dfbcf2a9db747a801d999a49198de2b091badf8efe141d22fddb9b35ec6c SHA512 33e0c53e3f16e312eee7db2395d0a5506150e60a47882a7531c9d082e0ca405aabd922b4774a507399d31f38feed78fb87a09efc5550f08dd3794703f1fab235 | ||
DIST ibus-typing-booster-2.9.4.tar.gz 8222228 BLAKE2B 8ba79ceaff6cd5ce37d093b08438a22ffb7b1295bba6d0b3af141b5804e89d04807d14fa5c5ce959ff728d76fcc5e60c0a51f113baa172710d59866733bd9741 SHA512 9c323301deccec0904cb2a2e34015ef11885ecd635ddb99afc6811a7f684dca448a026301155ae26fe0a38c00ca0a4d714ff933c39a60e4299434cfbca455d58 |
48 changes: 48 additions & 0 deletions
48
app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="7" | ||
PYTHON_COMPAT=( python3_{6,7,8} ) | ||
PYTHON_REQ_USE="sqlite(+)" | ||
|
||
inherit gnome2-utils python-single-r1 xdg | ||
|
||
DESCRIPTION="Completion input method for IBus" | ||
HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster" | ||
SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-3+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
RESTRICT="test" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
DEPEND="${PYTHON_DEPS} | ||
dev-libs/m17n-lib | ||
$(python_gen_cond_dep ' | ||
app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}] | ||
dev-python/dbus-python[${PYTHON_MULTI_USEDEP}] | ||
dev-python/pyenchant[${PYTHON_MULTI_USEDEP}] | ||
dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}] | ||
dev-python/pyxdg[${PYTHON_MULTI_USEDEP}] | ||
')" | ||
RDEPEND="${DEPEND} | ||
>=dev-db/m17n-db-1.7" | ||
BDEPEND="sys-devel/gettext | ||
virtual/pkgconfig" | ||
|
||
pkg_preinst() { | ||
xdg_pkg_preinst | ||
gnome2_schemas_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
gnome2_schemas_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_pkg_postrm | ||
gnome2_schemas_update | ||
} |