Skip to content

Commit

Permalink
app-backup/backintime: Version bump (thanks Yanestra for the hint, bu…
Browse files Browse the repository at this point in the history
…g 579560).

Package-Manager: portage-2.2.28
  • Loading branch information
xmw committed May 7, 2016
1 parent e3859c0 commit 21f7db9
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-backup/backintime/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST backintime-1.1.12.tar.gz 656192 SHA256 a835e4eccb70ea3e8156861750a4c93d33dbc0e8590daf390c5a54dcc6b0ee4c SHA512 e1dc3e3d2bac8b0f390898029978e806128ffd6005471a7e8a697c44f9e271f9902b496b33b037133f9a509f4ca3f8b8f10adf681b670ec9a1a751dfc786cb62 WHIRLPOOL 8ada493d2cbb38879bc7481899eb41fa235b9e4e7d3a003d40b230c32924e568a2fa0b43bbd875c734279f36d63dd678cd7eabf406a18cc4b7c45d716cacfae1
DIST backintime-1.1.8.tar.gz 617754 SHA256 a1f2d210e95633dfe383eb50b3b560d1e09c43de4ce89dd4cb193cab40cb8a1e SHA512 550e270dcf341ec5ad952f4decd836007d19ff9bf60cada834dfb488dbf29954b6fd3ed80a4f8fb4406a0166895a7f7c922e5622d06c43086dd54073e5aabd99 WHIRLPOOL ea9af3c432c61def4214e1d1e2c70e40cb7e50867bb0fa08930740c13133293ad135fd6c97295ab176deaedacb33e72583dc7c34dcfc3cb375a8b6e7fc7ab632
78 changes: 78 additions & 0 deletions app-backup/backintime/backintime-1.1.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python3_3 python3_4 )

inherit eutils python-single-r1

DESCRIPTION="Backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
HOMEPAGE="http://backintime.le-web.org/"
SRC_URI="http://${PN}.le-web.org/download/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="qt4"

DEPEND="${PYTHON_DEPS}
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
net-misc/openssh
net-misc/rsync[xattr,acl]"
RDEPEND="${DEPEND}
qt4? ( dev-python/PyQt4 )"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

src_prepare() {
#fix doc install location
sed -e "s:/doc/${PN}-common:/doc/${PF}:g" \
-i common/configure || die
sed -e "s:/doc/${PN}-qt4:/doc/${PF}:g" \
-i qt4/configure || die
sed -e "/addInstallFile \"..\/VERSION/d" \
-e "/addInstallFile \"..\/LICENSE/d" \
-e "/addInstallFile \"..\/debian\/copyright/d" \
-i {qt4,common}/configure || die

if [ -n ${LINGUAS+x} ] ; then
cd common/po || die
for po in *.po ; do
if ! has ${po/.po} ${LINGUAS} ; then
rm ${po} || die
fi
done
fi
}

src_configure() {
cd "${S}"/common || die
./configure --python3 --no-fuse-group || die
if use qt4 ; then
cd "${S}"/qt4 || die
./configure --python3 || die
fi
}

src_compile() {
cd "${S}"/common || die
emake
if use qt4 ; then
cd "${S}"/qt4 || die
emake
fi
}

src_install() {
cd "${S}"/common || die
emake DESTDIR="${D}" install
if use qt4 ; then
cd "${S}"/qt4 || die
emake DESTDIR="${D}" install
fi

python_optimize "${D}"
}

0 comments on commit 21f7db9

Please sign in to comment.