Skip to content

Commit

Permalink
dev-python/argcomplete: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
patricklauer committed Feb 26, 2016
1 parent afc5992 commit 2213667
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/argcomplete/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST argcomplete-0.8.1.tar.gz 30272 SHA256 12e36f784160547ca855a2c9d753cf60cd3f8
DIST argcomplete-0.8.9.tar.gz 30575 SHA256 98f04fa2ca22479459d8ba04583dca653a41c2d7a57648ba7f3b4d7e19ea82be SHA512 21b7d267f2d5a43a299841ca05b3b4dc38587e9ac90db8634d8e13d089e58483b88506376eff16d8ea2d03a169e118a5be32549b74c5168a337e6a6d22a01f7f WHIRLPOOL 336d7096a0dbfd3fa2beeacee6189fe375586ddec7dfe5277687149701bb52befcc83234de6ea59c06f662c20e44de00420b51fc640517055d5505374f0fcd26
DIST argcomplete-0.9.0.tar.gz 35214 SHA256 f97577332d19aea09583ecb426a49e85dc7bbc9822ab345b9c790d923413af0e SHA512 e127a8d2e7914f2601d649963115595db40ed612d352c134c5b68acdcbcd52477728e6e1edddd405562b28329f960d87d1418fa8fe3b3f1dcb9c3ad10c42a65d WHIRLPOOL 03c5f4eac0aeac9887d8ba1d21b585854b91c7399c95260ecf58f92d709b9194f801b730ab26435e329e003f8041c96d11410983a83c21f262cd2ad68a32a100
DIST argcomplete-1.0.0.tar.gz 35480 SHA256 2cba862e5ce5b0057a33169484544c38bfdc17a1dd865c197adb7ce07800e36e SHA512 9f974833d4e699d87e575a51c024ae7782f51f6e085be291bbac645b6e72873597be6da3c75b0461a8ef5a33311ce3d1fcb6e58f999ad043099331e269f5e9a6 WHIRLPOOL 52ce076077cb4dca8777e55a265351e817b9369af66635dd89b9b2dd3c6ef27e8329864f6024be70d786c42139ccd784d1e3535700a4bea304b2ce8611f1c407
DIST argcomplete-1.1.0.tar.gz 35809 SHA256 86eeb63632c00831d4c2a7f1158d3a102339a994763fd7492439811546129dc1 SHA512 189f2f417ca47834b97ae69a7bae8c601a7d5e4d22abbd7b927f9352752ab6b406f9b04593dfcb3eb45c5c5269bfbca38d68deb71101e275f13508ef5f23d13f WHIRLPOOL 2438700f41e4df004139d0b5f753e523966bf6394cdc5e0b2f46a3e62a6a2baa7f1f7b10d433f33115dde182fe7c480e0c5726e52940ae13ce67cd73e3c2aabc
39 changes: 39 additions & 0 deletions dev-python/argcomplete/argcomplete-1.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} )

inherit distutils-r1 bash-completion-r1

DESCRIPTION="Bash tab completion for argparse"
HOMEPAGE="https://pypi.python.org/pypi/argcomplete"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

SLOT="0"
LICENSE="Apache-2.0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE=""

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"

python_prepare_all() {
# purge test folder to avoid file collisions
sed -e "s:find_packages():find_packages(exclude=['test','test.*']):" -i setup.py || die
distutils-r1_python_prepare_all
}

python_test() {
${EPYTHON} test/test.py || die
}

python_install_all() {
sed \
-e "/complete /d" \
-i argcomplete/bash_completion.d/python-argcomplete.sh || die

distutils-r1_python_install_all
newbashcomp "${S}"/${PN}/bash_completion.d/python-argcomplete.sh python-${PN}
}

0 comments on commit 2213667

Please sign in to comment.