Skip to content

Commit

Permalink
net-vpn/tor: version bump to 0.3.2.8_rc
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.3
  • Loading branch information
blueness committed Dec 22, 2017
1 parent 4bcf4d9 commit 22223f7
Show file tree
Hide file tree
Showing 2 changed files with 83 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-vpn/tor/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST tor-0.3.1.7.tar.gz 6058284 BLAKE2B f2d825c82342cf1ca9354f051d532ef31e1d183be28f0f5b49f14c0d88176910292b6727b8cf0f066bae276e3a431851714cdb385219516d0a7519c5ed02b203 SHA512 a835526984187fad88cffc39ea8f6a4b61d5f8d2579b5a66425612607a22ff82e0f9da96e029e134e04d25ae0f59a1b4f771e9e8c19ebb563e1a0f5b3a3849e4
DIST tor-0.3.1.9.tar.gz 6092702 BLAKE2B c009567b5866ff50159fbcbab05462a860c3e66c15599d11d40495d8a1a18fbad610f8ea94492519f2c8b6adfce7f4a54ad3bd2aee2b902ffae7215f35a3d4d5 SHA512 c22557251272595c65b2fade485020d76de16f5bb826d4a47d7bd093b7336dad42e8e2b8a3e0c56d9a10e62f0a5b1596c4b10cd578bf6da17f058f3d4e356f66
DIST tor-0.3.2.7-rc.tar.gz 6313975 BLAKE2B ecfe6832b2e9c81f04218f7ec82a63f23913c1dc0a9ec29113e6432eac69b8cc89a9fc6b7c4147cf26e6de141b22574d3118608194641126d961b5f452179e1b SHA512 989bdd4311521528444f4165455365d3c1f1ef5f6a8846bf08db7f84ab8e986cba47f9dfbd3a03ccb6e3f8d813d69289768170a8fd68916e9d6a21fe0484cf87
DIST tor-0.3.2.8-rc.tar.gz 6345141 BLAKE2B e529847252b819a81e6cce5f5989e72ccb9d8db03221c37e504b47995d36977a67653d59cb7f8378eb3652d256867e3ee319062f9cb6acdcd42a415b08f89954 SHA512 60913c492f903307d485af26ab3752e0058fb97816d62cd29eb8785446bb7eb6f9bd2aca964a0d8c4de039c4d432590dea68c28c4f34eda2f127b50c752be0d4
82 changes: 82 additions & 0 deletions net-vpn/tor/tor-0.3.2.8_rc.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit flag-o-matic readme.gentoo-r1 systemd versionator user

MY_PV="$(replace_version_separator 4 -)"
MY_PF="${PN}-${MY_PV}"
DESCRIPTION="Anonymizing overlay network for TCP"
HOMEPAGE="http://www.torproject.org/"
SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
S="${WORKDIR}/${MY_PF}"

LICENSE="BSD GPL-2"
SLOT="0"
# We need to keyword app-arch/zstd
#KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~ppc-macos"
IUSE="libressl lzma scrypt seccomp selinux systemd tor-hardening test web zstd"

DEPEND="
app-text/asciidoc
dev-libs/libevent[ssl]
sys-libs/zlib
!libressl? ( dev-libs/openssl:0=[-bindist] )
libressl? ( dev-libs/libressl:0= )
lzma? ( app-arch/xz-utils )
scrypt? ( app-crypt/libscrypt )
seccomp? ( sys-libs/libseccomp )
systemd? ( sys-apps/systemd )
zstd? ( app-arch/zstd )"
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-tor )"

PATCHES=(
"${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
)

DOCS=( README ChangeLog ReleaseNotes doc/HACKING )

pkg_setup() {
enewgroup tor
enewuser tor -1 -1 /var/lib/tor tor
}

src_configure() {
econf \
--localstatedir="${EPREFIX}/var" \
--enable-system-torrc \
--enable-asciidoc \
--disable-libfuzzer \
--disable-rust \
$(use_enable lzma) \
$(use_enable scrypt libscrypt) \
$(use_enable seccomp) \
$(use_enable systemd) \
$(use_enable tor-hardening gcc-hardening) \
$(use_enable tor-hardening linker-hardening) \
$(use_enable web tor2web-mode) \
$(use_enable test unittests) \
$(use_enable test coverage) \
$(use_enable zstd)
}

src_install() {
default
readme.gentoo_create_doc

newconfd "${FILESDIR}"/tor.confd tor
newinitd "${FILESDIR}"/tor.initd-r8 tor
systemd_dounit contrib/dist/tor.service

keepdir /var/lib/tor

fperms 750 /var/lib/tor
fowners tor:tor /var/lib/tor

insinto /etc/tor/
newins "${FILESDIR}"/torrc-r1 torrc
}

0 comments on commit 22223f7

Please sign in to comment.